Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Launch RCP App without plugins folder
Launch RCP App without plugins folder [message #99249] Wed, 03 October 2007 13:30 Go to next message
Eclipse UserFriend
Originally posted by:

Hi there!

I am currently trying to programmatically start a simple RCP Application in Equinox. Unlike all the examples I found on the net, we do not have the necessary bundles in a "plugins" folder, but we are using Spring OSGi's integration test harness for installing and activating them - we are doing this, because we are also using the integration test harness for our server bundles.

So we don't have a plugins-folder, we don't have a config.ini, and the bundles are installed into the Equinox runtime (which is internally started using the <code>EclipseStarter</code>) and activated by the integration test harness.

My question is: is this possible at all? If yes, what is the (my?) problem?

Here is what I have tried up to now:
As soon as I had all necessary bundles up-and-"ACTIVE" in Equinox, and the Application was still not showing up, I started playing 'round with some Runtime options:

<code>-Declipse.application=testplugin.Application -Declipse.ignoreApp=false</code>

... which produced the error message <i>Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini)</i> at the next startup. And entering <code>apps</code> in the OSGi console only displays the <code> [running] [not launchable]</code>-application.

Please correct me if I'm wrong, but I think what had happened was, that the runtime was trying to start the testplugin.Application <b>before</b> the integration test harness had activated all the necessary bundles (like <code>org.eclipse.core.runtime</code>).

So I tried to defer starting the RCP application (until all necessary bundles are activated) using some other runtime options (like eclipse.application.launchDefault, eclipse.application.registerDescriptors, eclipse.ignoreApp or eclipse.activateRuntimePlugins), but none of the combinations I tried seemed to work: <code>apps</code> does not display any apps and the <code></code> bundle does not register any ApplicationDescriptor or ApplicationHandle.

Just to rule out the most obvious sources for the problem: the plugin.xml looks ok (and the RCP App can be started from inside Eclipse) and all bundles (including the RCP App itself) are happily resolved and activated.

So back to my question: is this possible at all? If yes, could you please point me into the right direction (which runtime options to set, ...)? A link to a detailled description of the startup-process of an RCP App would also help me a lot!

Thank you very much in advance,
Re: Launch RCP App without plugins folder [message #992725 is a reply to message #99249] Sat, 22 December 2012 12:17 Go to previous message
Zoltan Ujhelyi is currently offline Zoltan UjhelyiFriend
Messages: 380
Registered: July 2015
Senior Member
Hi Henrik,

thank you for the pointer. Seems a usable way - at least now I see what I am supposed to override if all else fails.

Currently, I am rather thinking about providing a solution inside the Xtext scoping mechanism, but for now, I am laying the issue rest a few days. Maybe after that everything will become clearer.

Thank again,
Previous Topic:Debugging Declarative Services resolution
Next Topic:Certificate Problem with Headless installing plugins
Goto Forum:

Current Time: Sat Oct 23 02:55:27 GMT 2021

Powered by FUDForum. Page generated in 0.01533 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top