Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Visual Editor (VE) » Unable to get VE to work
Unable to get VE to work [message #99145] Fri, 22 July 2005 11:53 Go to next message
Eclipse UserFriend
Originally posted by: natarajv.eml.cc

Hi,


We had been trying to get VE (with SWT support) to work for us for the
past few weeks, without any success.

I had tried the following combinations recently
1)
eclipse-SDK-3.0.2-win32.zip
emf-sdo-runtime-2.0.2.zip
GEF-runtime-3.0.1.zip
VE-runtime-1.0.2.2.zip

---

2)
eclipse-SDK-3.0.1-win32.zip
VE-runtime-1.1RC2.zip
GEF-runtime-3.1.zip
emf-sdo-runtime-2.1.0.zip

When I tried with VE 1.0.2.2, I was able to get the SWING/VE working. But
I was never able to get SWT to work.

Most of the errors (in VE1.1RC1 and in VE1.0.2.2)are due to any of the
following:
1. org.eclipse.swt.SWTException: Failed to execute runnable
(java.lang.NoSuchMethodError: org.eclipse.swt.graphics.GC.getAdvanced()Z)
2. java.lang.NoClassDefFoundError: org.eclipse.swt.widgets.Widget

I dont know where I have to add the java.library.path for the plugin under
Eclipse 3.1. The plugin is not able to find the windows DLLs.

Please help.


Regards,
V. Natarajan
Re: Unable to get VE to work [message #99232 is a reply to message #99145] Fri, 22 July 2005 14:34 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: richkulp.us.NO_SPAM.ibm.com

You can not mix VE 1.1 with 3.0.1. You cannot mix VE 1.0.x with 3.1.
They are not interchangable.

We are releasing today the final release of VE 1.1, so you should be
using that with its required prereqs (which is listed on the download page).

--
Thanks,
Rich Kulp
Re: Unable to get VE to work [message #99674 is a reply to message #99232] Sun, 24 July 2005 02:41 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: natarajv.eml.cc

Rich Kulp wrote:
> You can not mix VE 1.1 with 3.0.1. You cannot mix VE 1.0.x with 3.1.
> They are not interchangable.
>
> We are releasing today the final release of VE 1.1, so you should be
> using that with its required prereqs (which is listed on the download
> page).
>
Oops, A typo over there. I used Eclipse SDK 3.1 only. But still I wasnt
able to get it working at all. Infact, I downloaded everything as
specified in the download page of VE 1.0.2.2 and VE 1.1RC1 separately.
Still, I wasnt able to get it working.

Okay, I will try to use the latest release 1.1, with my existing Eclipse
SDK 3.1, EMF 2.1 & GEF 3.1 with Sun JRE 5.

What I do is just to unzip the files into C:\ and start Eclipse with
-clean option.

Is there anything else that I should be doing to get this stuff to work?
(Downloading zip files over here in my place takes a long process of
approvals and third person doing the stuff... :( Have to wait till
monday evening to get my hands on it.)

Thanks and Regards,

Natarajan
Re: Unable to get VE to work [message #100209 is a reply to message #99674] Tue, 26 July 2005 14:49 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: richkulp.us.NO_SPAM.ibm.com

Just make sure you have a brand new installation. That works best. If
you have an older version sitting around and you install on top of it
there could be problems. Especially if you have a previous development
driver of EMF 2.1 or GEF 3.1 before they converted to using jars for the
plugins instead of directories. If you have that it will never pick up
the final versions of EMF or GEF.

Natarajan wrote:
> Rich Kulp wrote:
>
>> You can not mix VE 1.1 with 3.0.1. You cannot mix VE 1.0.x with 3.1.
>> They are not interchangable.
>>
>> We are releasing today the final release of VE 1.1, so you should be
>> using that with its required prereqs (which is listed on the download
>> page).
>>
> Oops, A typo over there. I used Eclipse SDK 3.1 only. But still I wasnt
> able to get it working at all. Infact, I downloaded everything as
> specified in the download page of VE 1.0.2.2 and VE 1.1RC1 separately.
> Still, I wasnt able to get it working.
>
> Okay, I will try to use the latest release 1.1, with my existing Eclipse
> SDK 3.1, EMF 2.1 & GEF 3.1 with Sun JRE 5.
>
> What I do is just to unzip the files into C:\ and start Eclipse with
> -clean option.
>
> Is there anything else that I should be doing to get this stuff to work?
> (Downloading zip files over here in my place takes a long process of
> approvals and third person doing the stuff... :( Have to wait till
> monday evening to get my hands on it.)
>
> Thanks and Regards,
>
> Natarajan

--
Thanks,
Rich Kulp
Re: Unable to get VE to work [message #100329 is a reply to message #99145] Tue, 26 July 2005 18:54 Go to previous message
Ferad Zyulkyarov is currently offline Ferad ZyulkyarovFriend
Messages: 20
Registered: July 2009
Junior Member
Hi, I have the same problem. Later I realized that the error dues to
version incompatability. Just try to install the latest version of
eclipse, ve, gef.

Ferad Zyulkyarov
Re: Unable to get VE to work [message #609180 is a reply to message #99145] Fri, 22 July 2005 14:34 Go to previous message
Eclipse UserFriend
Originally posted by: richkulp.us.NO_SPAM.ibm.com

You can not mix VE 1.1 with 3.0.1. You cannot mix VE 1.0.x with 3.1.
They are not interchangable.

We are releasing today the final release of VE 1.1, so you should be
using that with its required prereqs (which is listed on the download page).

--
Thanks,
Rich Kulp
Re: Unable to get VE to work [message #609206 is a reply to message #99232] Sun, 24 July 2005 02:41 Go to previous message
Eclipse UserFriend
Originally posted by: natarajv.eml.cc

Rich Kulp wrote:
> You can not mix VE 1.1 with 3.0.1. You cannot mix VE 1.0.x with 3.1.
> They are not interchangable.
>
> We are releasing today the final release of VE 1.1, so you should be
> using that with its required prereqs (which is listed on the download
> page).
>
Oops, A typo over there. I used Eclipse SDK 3.1 only. But still I wasnt
able to get it working at all. Infact, I downloaded everything as
specified in the download page of VE 1.0.2.2 and VE 1.1RC1 separately.
Still, I wasnt able to get it working.

Okay, I will try to use the latest release 1.1, with my existing Eclipse
SDK 3.1, EMF 2.1 & GEF 3.1 with Sun JRE 5.

What I do is just to unzip the files into C:\ and start Eclipse with
-clean option.

Is there anything else that I should be doing to get this stuff to work?
(Downloading zip files over here in my place takes a long process of
approvals and third person doing the stuff... :( Have to wait till
monday evening to get my hands on it.)

Thanks and Regards,

Natarajan
Re: Unable to get VE to work [message #609250 is a reply to message #99674] Tue, 26 July 2005 14:49 Go to previous message
Eclipse UserFriend
Originally posted by: richkulp.us.NO_SPAM.ibm.com

Just make sure you have a brand new installation. That works best. If
you have an older version sitting around and you install on top of it
there could be problems. Especially if you have a previous development
driver of EMF 2.1 or GEF 3.1 before they converted to using jars for the
plugins instead of directories. If you have that it will never pick up
the final versions of EMF or GEF.

Natarajan wrote:
> Rich Kulp wrote:
>
>> You can not mix VE 1.1 with 3.0.1. You cannot mix VE 1.0.x with 3.1.
>> They are not interchangable.
>>
>> We are releasing today the final release of VE 1.1, so you should be
>> using that with its required prereqs (which is listed on the download
>> page).
>>
> Oops, A typo over there. I used Eclipse SDK 3.1 only. But still I wasnt
> able to get it working at all. Infact, I downloaded everything as
> specified in the download page of VE 1.0.2.2 and VE 1.1RC1 separately.
> Still, I wasnt able to get it working.
>
> Okay, I will try to use the latest release 1.1, with my existing Eclipse
> SDK 3.1, EMF 2.1 & GEF 3.1 with Sun JRE 5.
>
> What I do is just to unzip the files into C:\ and start Eclipse with
> -clean option.
>
> Is there anything else that I should be doing to get this stuff to work?
> (Downloading zip files over here in my place takes a long process of
> approvals and third person doing the stuff... :( Have to wait till
> monday evening to get my hands on it.)
>
> Thanks and Regards,
>
> Natarajan

--
Thanks,
Rich Kulp
Re: Unable to get VE to work [message #610015 is a reply to message #99145] Tue, 26 July 2005 18:54 Go to previous message
Ferad Zyulkyarov is currently offline Ferad ZyulkyarovFriend
Messages: 20
Registered: July 2009
Junior Member
Hi, I have the same problem. Later I realized that the error dues to
version incompatability. Just try to install the latest version of
eclipse, ve, gef.

Ferad Zyulkyarov
Previous Topic:XSWT support?
Next Topic:Applet context in Visual Editor
Goto Forum:
  


Current Time: Sat Jul 21 19:39:19 GMT 2018

Powered by FUDForum. Page generated in 0.02848 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top