Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Problem with validation(I can't use the CheckFragment)
Problem with validation [message #814300] Tue, 06 March 2012 09:30 Go to next message
Massimo Missing name is currently offline Massimo Missing nameFriend
Messages: 5
Registered: October 2011
Junior Member
Hi all!

I've a problem with a validation. I have to check some things in my grammar and searching in internet I found that I should add to my mwe2 file this strings:

fragment = org.eclipse.xtext.generator.validation.JavaValidatorFragment {}
fragment = org.eclipse.xtext.generator.validation.CheckFragment {}


No problem with the first but the latter say me this:
Quote:
Couldn't resolve reference to JvmType 'org.eclipse.xtext.generator.validation.CheckFragment'.

and I can't resolve it.

Any suggestion?


Another question: I've a deep tree for the ecore model, ho can I acces to the leaves? Should I use "Root.arm. ... .arm.leave"?
Maybe these are stupid questions but I'm newbie with this stuff and I've to do this for a school project.

Thank you,
Max

Thank you
Re: Problem with validation [message #814315 is a reply to message #814300] Tue, 06 March 2012 09:54 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3107
Registered: July 2009
Senior Member
Hi Massimo,

please refer to the docs if you want to learn about the validation API.
The CheckFragment was deprecated in 1.0 and removed in Xtext 2.0. It was
sort of an alternative the JavaValidatorFragment.

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 06.03.12 10:30, schrieb Massimo Mising name:
> Hi all!
>
> I've a problem with a validation. I have to check some things in my
> grammar and searching in internet I found that I should add to my mwe2
> file this strings:
>
>
> fragment = org.eclipse.xtext.generator.validation.JavaValidatorFragment {}
> fragment = org.eclipse.xtext.generator.validation.CheckFragment {}
>
>
> No problem with the first but the latter say me this:
> Quote:
>> Couldn't resolve reference to JvmType
>> 'org.eclipse.xtext.generator.validation.CheckFragment'.
>
> and I can't resolve it.
>
> Any suggestion?
>
>
> Another question: I've a deep tree for the ecore model, ho can I acces
> to the leaves? Should I use "Root.arm. ... .arm.leave"?
> Maybe these are stupid questions but I'm newbie with this stuff and I've
> to do this for a school project.
>
> Thank you,
> Max
>
> Thank you
Re: Problem with validation [message #814321 is a reply to message #814315] Tue, 06 March 2012 10:04 Go to previous message
Massimo Missing name is currently offline Massimo Missing nameFriend
Messages: 5
Registered: October 2011
Junior Member
Ok, thanks
Previous Topic:JvmModelGenerator seems to does not generate enumeration type.
Next Topic:Generic grammar makes Eclipse throw OutOfMemoryError when running editor
Goto Forum:
  


Current Time: Mon Mar 30 14:45:59 GMT 2020

Powered by FUDForum. Page generated in 0.02828 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top