Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Failed to resolve a bundle with Equniox 3.6.2. Please help(Failed to resolve a bundle which depends on 3-rd jar )
Failed to resolve a bundle with Equniox 3.6.2. Please help [message #808878] Tue, 28 February 2012 08:49
Chao Zhang is currently offline Chao ZhangFriend
Messages: 1
Registered: February 2012
Junior Member
Hi:

We have a War project which is deployed on WebSphere. We used the Equniox3.3.1 in our War before but recently we want to upgrade to 3.6.2.

Our jars(dataservice.adaptors.clearquest) depends on ClearQuest provided jar: wvcm.stp, After we deployed the war on WebSphere and start our application, the dataservice.adaptors.clearquest can not be resolved by OSGI, I tried to turn on all OSGI debug options and got the following message:
[2/28/12 14:47:36:437 GMT+08:00] 00000016 SystemOut O Trying to resolve: [com.dataservices.adaptors.clearquest_1.0.0.v20120224_0730], com.ibm.rational.wvcm.stp
[2/28/12 14:47:36:453 GMT+08:00] 00000016 SystemOut O ** IMPORT com.ibm.rational.wvcm.stp[com.dataservices.adaptors.clearquest_1.0.0.v20120224_0730] failed to resolve
[2/28/12 14:47:36:453 GMT+08:00] 00000016 SystemOut O [com.dataservices.adaptors.clearquest_1.0.0.v20120224_0730] NOT RESOLVED

I didn't see any useful error message here, it only said IMPORTING com.ibm.rationl.wvcm.stp and then told me failed to resolve my jar. I can confirm that the com.ibm.rational.wvcm.stp is added in classpath through checking WebSphere admin console. The following logs can make sure it is in classpath:
[2/28/12 14:47:35:437 GMT+08:00] 00000013 SystemOut O parseHeader: .
[2/28/12 14:47:35:437 GMT+08:00] 00000013 SystemOut O parseHeader: com.ibm.rational.wvcm.stp
[2/28/12 14:47:35:437 GMT+08:00] 00000013 SystemOut O parseHeader: com.ibm.rational.wvcm.stp.cq
[2/28/12 14:47:35:437 GMT+08:00] 00000013 SystemOut O parseHeader: com.rational.clearquest.cqjni
[2/28/12 14:47:35:437 GMT+08:00] 00000013 SystemOut O parseHeader: javax.wvcm

I can not find out any message to tell me what's wrong with it and how I can solve it. So I come here and ask your help.
Could you please tell me how to get more useful information or how I can fix it?
BTW, it can work with Equniox3.3.1
Thanks a lot!!!
Previous Topic:How to install the plugins of Dropins for my RCP Application?
Next Topic:How to accept certificates p2.director
Goto Forum:
  


Current Time: Sun Oct 17 04:38:49 GMT 2021

Powered by FUDForum. Page generated in 0.01621 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top