Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Test and Performance Tools Platform (TPTP) » can't launch agent controller server on linux, missing libraries
can't launch agent controller server on linux, missing libraries [message #96543] Fri, 20 April 2007 17:59 Go to next message
Natasha D'Silva is currently offline Natasha D'SilvaFriend
Messages: 25
Registered: July 2009
Junior Member
I installed the AC server version 4.2.2 for linux from here:
and unzipped the runtime and sdk. I ran SetConfig and tried to launch the
server but it failed with this error:
"error while loading shared libraries: cannot open shared
object file: No such file or directory"
In the lib directory, I noticed that some of the libraries are actually
links to links to older versions of themselves,
so for example,> ->
I googled this and found someone with the same problem: html
The output of ldd
$ ldd => /lib/ (0x00a7d000) => /lib/ (0x00b81000) => not found => /lib/tls/ (0x00adc000) => /lib/tls/ (0x00845000)
/lib/ (0x00827000)
I have tried unzipping with the built in File Roller as well as the command
line unzip.
I have in the folder, 5.0M.
I am running GNU/Linux.
Any help is really appreciated,
Re: can't launch agent controller server on linux, missing libraries [message #96560 is a reply to message #96543] Sat, 21 April 2007 04:48 Go to previous message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Natasha,

Please ensure that $AC_HOME/lib directory is added to your LD_LIBRARY_PATH.
You may don't care about it if you launch Agent Controller by the command from $AC_HOME/bin.

Previous Topic:Application controlled start/stop profiling within eclipse
Next Topic:Starting the Agent for Profiling?
Goto Forum:

Current Time: Sat Aug 08 19:13:50 GMT 2020

Powered by FUDForum. Page generated in 0.02496 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top