Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Installation problems with Papyrus 0.9.0
Installation problems with Papyrus 0.9.0 [message #805084] Thu, 23 February 2012 10:10 Go to next message
Wolfgang Missing name is currently offline Wolfgang Missing nameFriend
Messages: 3
Registered: February 2012
Junior Member
Hello!

I cannot install the actual version of Papyrus 0.9.0 M5 - dependencies cannot be resolved (see below). Which packages are needed to install?

I used the actual Eclipse Modeling Framework package (download today: "eclipse-modeling-indigo-SR2-win32.zip").

Beyond: where can I find a description of the features of Papyrus 0.9.0? What are the differences to Papyrus 0.8.2?

Thank you!


Quote:

Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus SDK Binaries (Incubation) 0.9.0.v201202011116 (org.eclipse.papyrus.sdk.feature.feature.group 0.9.0.v201202011116)
Missing requirement: Papyrus Tools 0.9.0.v201202011116 (org.eclipse.papyrus.infra.tools 0.9.0.v201202011116) requires 'bundle org.eclipse.core.databinding 1.4.1' but it could not be found
Cannot satisfy dependency:
From: Papyrus customization (Incubation) 0.9.0.v201202011116 (org.eclipse.papyrus.customization.feature.feature.group 0.9.0.v201202011116)
To: org.eclipse.papyrus.customization.properties [0.9.0.v201202011116]
Cannot satisfy dependency:
From: Papyrus properties customization (Incubation) 0.9.0.v201202011116 (org.eclipse.papyrus.customization.properties 0.9.0.v201202011116)
To: bundle org.eclipse.papyrus.infra.widgets 0.9.0
Cannot satisfy dependency:
From: Papyrus widgets (Incubation) 0.9.0.v201202011116 (org.eclipse.papyrus.infra.widgets 0.9.0.v201202011116)
To: bundle org.eclipse.papyrus.infra.tools 0.9.0
Cannot satisfy dependency:
From: Papyrus SDK Binaries (Incubation) 0.9.0.v201202011116 (org.eclipse.papyrus.sdk.feature.feature.group 0.9.0.v201202011116)
To: org.eclipse.papyrus.customization.feature.feature.group [0.9.0.v201202011116]
Re: Installation problems with Papyrus 0.9.0 [message #805091 is a reply to message #805084] Thu, 23 February 2012 10:20 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 943
Registered: February 2011
Senior Member
Hello,

Papyrus 0.9M5 is compatible with Eclipse 3.8 and Eclipse 4.2 (Juno).

It is not compatible with Eclipse 3.7 (Indigo).

Papyrus 0.9 supports UML 2.4.1, and will bring new features :

http://wiki.eclipse.org/MDT/Papyrus/Ongoing (This page is not exhaustive).
http://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/modeling/mdt/papyrus/project-info/plan_juno.xml&component=Papyrus (More detailed)


Camille Letavernier
Re: Installation problems with Papyrus 0.9.0 [message #805157 is a reply to message #805091] Thu, 23 February 2012 12:09 Go to previous messageGo to next message
Wolfgang Missing name is currently offline Wolfgang Missing nameFriend
Messages: 3
Registered: February 2012
Junior Member
Thank you for the information!

By the way: the installation of Papyrus 0.8.2 on Eclipse Modeling Indigo SR2 does not work, too.

I will try now Eclipse Indigo SR1...
Re: Installation problems with Papyrus 0.9.0 [message #805169 is a reply to message #805157] Thu, 23 February 2012 12:28 Go to previous messageGo to next message
Wolfgang Missing name is currently offline Wolfgang Missing nameFriend
Messages: 3
Registered: February 2012
Junior Member
Independent of the Eclipse Indigo-Version the problem arises.
It seems to be, that this is a problem of Papyrus 0.8.2 SR2_RC4 ?!

The error "'Installing software' has encountered a problem. An error occured while collecting items to be installed." appears:

Quote:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.modeling, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.google.collect,1.0.0.v201105210816
No repository found containing: osgi.bundle,com.google.inject,2.0.0.v201105231817
No repository found containing: osgi.bundle,net.sourceforge.nattable.core,2.1.0.v201102231538
No repository found containing: osgi.bundle,org.antlr.runtime,3.2.0.v201101311130
No repository found containing: osgi.bundle,org.aopalliance,1.0.0.v201105210816
No repository found containing: osgi.bundle,org.apache.commons.cli,1.2.0.v201105210650
No repository found containing: osgi.bundle,org.apache.log4j,1.2.15.v201012070815
No repository found containing: osgi.bundle,org.eclipse.emf.facet.common.core,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.common.ui,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.efacet,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.browser,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.browser.custom,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.browser.custom.core,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.browser.custom.edit,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.browser.custom.ui,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.browser.uicore,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.common.core,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.common.ui,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.facet,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.facet.core,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.facet.edit,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.facet.editor,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.facet.ui,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.query,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.query.core,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.query.edit,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.query.editor,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.infra.query.ui,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.query.java,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.util.core,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.util.emf.catalog,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.util.emf.core,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.util.emf.ui,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets.celleditors,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets.celleditors.ecore,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets.celleditors.edit,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets.nattable,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets.nattable.instance,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets.nattable.instance.edit,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets.nattable.tableconfiguration,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets.nattable.tableconfiguration.edit,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.facet.widgets.nattable.workbench,0.1.1.v201109140754
No repository found containing: osgi.bundle,org.eclipse.emf.mwe.core,1.1.1.v201108020506
No repository found containing: osgi.bundle,org.eclipse.emf.mwe.utils,1.1.1.v201108020506
No repository found containing: osgi.bundle,org.eclipse.emf.mwe2.language,2.0.1.v201108020809
No repository found containing: osgi.bundle,org.eclipse.emf.mwe2.launch,2.0.1.v201108020809
No repository found containing: osgi.bundle,org.eclipse.emf.mwe2.lib,2.0.1.v201108020506
No repository found containing: osgi.bundle,org.eclipse.emf.mwe2.runtime,2.0.1.v201108020506
Problems downloading artifact: osgi.bundle,org.eclipse.epf.common,1.5.0.201105160919.
File has invalid content:C:\DOCUME~1\e0400gs0\LOCALS~1\Temp\signatureFile5845868568558339349.jar
Invalid content:common.jar
The file "common.jar" in the jar "C:\DOCUME~1\e0400gs0\LOCALS~1\Temp\signatureFile5845868568558339349.jar" has been tampered!
No repository found containing: osgi.bundle,org.eclipse.ocl.examples.common,3.1.0.v20110526-1523
No repository found containing: osgi.bundle,org.eclipse.ocl.examples.library,3.1.0.v20110526-1523
No repository found containing: osgi.bundle,org.eclipse.ocl.examples.modelregistry,3.1.0.v20110526-1523
No repository found containing: osgi.bundle,org.eclipse.ocl.examples.pivot,3.1.1.v20110826-0707
No repository found containing: osgi.bundle,org.eclipse.ocl.examples.xtext.base,3.1.1.v20110818-1948
No repository found containing: osgi.bundle,org.eclipse.ocl.examples.xtext.essentialocl,3.1.0.v20110826-0707
No repository found containing: osgi.bundle,org.eclipse.ocl.examples.xtext.essentialocl.ui,3.1.0.v20110826-0707
No repository found containing: osgi.bundle,org.eclipse.team.svn.core,0.7.9.I20110819-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.ui,0.7.9.I20110819-1700
No repository found containing: osgi.bundle,org.eclipse.xpand,1.1.0.v201108020519
No repository found containing: osgi.bundle,org.eclipse.xtend,1.1.0.v201108020519
No repository found containing: osgi.bundle,org.eclipse.xtend.typesystem.emf,1.0.1.v201108020519
No repository found containing: osgi.bundle,org.eclipse.xtext,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.xtext.builder,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.xtext.common.types,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.xtext.common.types.ui,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.xtext.generator,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.xtext.ui,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.xtext.ui.shared,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.xtext.util,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.xtext.xbase.lib,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.xtext.xtend2.lib,2.0.1.v201108020636
No repository found containing: osgi.bundle,org.eclipse.zest.layouts,1.1.0.v20110425-2050

Re: Installation problems with Papyrus 0.9.0 [message #805175 is a reply to message #805169] Thu, 23 February 2012 12:38 Go to previous message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 943
Registered: February 2011
Senior Member
Which update site(s) do you use ? And, which base platform ? Indigo SR2 will be released tomorrow, and Papyrus is part of the train ; as well as all the plug-ins listed in your error message. I'm not sure how the dependencies work until the official release. I think there are a few temporary update sites to install a full SR2 before it is actually released, but I don't know where to find them.

I haven't met any problem to install Papyrus 0.8.2 on Indigo SR1 from the various milestone update sites, but I think it's a little more complicated to install it on Indigo SR2.


Camille Letavernier
Previous Topic:model.di is empty
Next Topic:Papyrus 0.8.2
Goto Forum:
  


Current Time: Wed Apr 21 03:04:44 GMT 2021

Powered by FUDForum. Page generated in 0.02437 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top