Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Setup with IIS under Vista 64
Setup with IIS under Vista 64 [message #96286] Mon, 13 April 2009 00:10 Go to next message
Frank Mullin is currently offline Frank MullinFriend
Messages: 3
Registered: July 2009
Junior Member
Why isn't php5isapi.dll included in the php plugin materials for eclipse?
To get PDT running under Vista 64 with IIS 7 (rather than apache), I
followed the instructions given at
http://www.brucebarrera.com/how-to-install-php-5-and-mysql-o n-iis-7-and-windows-vista-windows-7/
Unfortunately, ther file php5isapi.dll wasn't part of the eclipse package
so I got it from the Zend php package and moved it into the folder with
the other php stuff in Eclipse.
I still had a problem because I was running under vista 64 but fortunately
I found an answer at
http://www.hanselman.com/blog/HTTPError40417PHPOnIIS7Under64 bitVista.aspx
I guess my question is -- is there a better way to do this that doesn't
require getting the extra file (php5isapi.dll) from the full php stuff?
Re: Setup with IIS under Vista 64 [message #96506 is a reply to message #96286] Sat, 18 April 2009 13:23 Go to previous message
Roy Ganor is currently offline Roy GanorFriend
Messages: 150
Registered: July 2009
Senior Member
I know that I am biased here a little bit, but I suggest you to install
Zend Server - Community Edition which fully supports these operations.

- Roy


Frank Mullin wrote:

> Why isn't php5isapi.dll included in the php plugin materials for eclipse?
> To get PDT running under Vista 64 with IIS 7 (rather than apache), I
> followed the instructions given at
>
http://www.brucebarrera.com/how-to-install-php-5-and-mysql-o n-iis-7-and-windows-vista-windows-7/
> Unfortunately, ther file php5isapi.dll wasn't part of the eclipse package
> so I got it from the Zend php package and moved it into the folder with
> the other php stuff in Eclipse.
> I still had a problem because I was running under vista 64 but fortunately
> I found an answer at
> http://www.hanselman.com/blog/HTTPError40417PHPOnIIS7Under64 bitVista.aspx
> I guess my question is -- is there a better way to do this that doesn't
> require getting the extra file (php5isapi.dll) from the full php stuff?
Previous Topic:Enabling MySQLi support with Zend PDT
Next Topic:Conditional Breakpoints won't "Catch" in PDT 2.0
Goto Forum:
  


Current Time: Wed Feb 01 03:56:16 GMT 2023

Powered by FUDForum. Page generated in 0.04156 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top