Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Making p2 more end user friendly
Making p2 more end user friendly [message #804262] Wed, 22 February 2012 11:45
Thorsten Meinl is currently offline Thorsten MeinlFriend
Messages: 85
Registered: July 2009
Member
We get quite a lot of complaints from users that find the update
mechanism in our Eclipse-based product to complicated. The most common
issue is that they install a new feature which requires plug-ins in
newer version than are currently installed (by some other feature).
Eclipse detects this but the error message is hard to understand for
end-users ("Cannot complete the install because of a conflicting
dependency..."). The problem can usually be resolved by also updating
the feature the brings the too-old plug-in with it. Thus I was thinking
of extending the install dialog so that it offers a potential solution
to the problem, e.g. "You also need to update feature xyz".
First question: are there any plans to add such a mechanism to Eclipse?
Second question: is it possible to extend the install procedure myself
and where should I start then?

Cheers,

Thorsten
Previous Topic:"dropins" folder in RCP application
Next Topic:Eclipse Laucher and ini files
Goto Forum:
  


Current Time: Thu Oct 21 19:24:16 GMT 2021

Powered by FUDForum. Page generated in 0.01749 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top