Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse does paste twice on single Ctrl+V(When I use context menu and click on paste, everything is ok, but on Ctrl+V shortcut Eclipse pastes from clipboard two same texts.)
Eclipse does paste twice on single Ctrl+V [message #797430] Mon, 13 February 2012 13:30 Go to next message
Petr Mruzek is currently offline Petr MruzekFriend
Messages: 1
Registered: February 2012
Junior Member
Hello,

please excuse my English, I'll try my best.

I'm czech programmer and I use czech QWERTZ keyboard.

Here is my problem:

In QWERTZ, special characters as "<", ">", "[", "{", "@" etc. are only available by their right Alt+ shortcuts.
For example
"<" is RightAlt+,
"@" is RightAlt+V
...

I use these shortcuts for a long time so it would be terrifying to start with using EN keyboard.

When I use RightAlt+, each editor take me '<' character. But in Eclipse I get ",<".
I don't know how is this possible. The worst thing is, that when I wait some time, this behavior dissapear for moment and after short writing it came back.

Next issue is that Numeric Pad writes double digits. I push '8' and I get "88".

All of that I could suffer, but Double copy issue i can't.

Ctrl+C works normally (copied "some string")
Ctrl+V gives me sometimes "some stringsome string".
Context menu and Paste selection gives me normal result ("some string").

In Preferences when I want to set shortcut, I push it and it appears twice in dialog.

What can I do to stop this?

OS: Windows 7 Professional SP1
Eclipse Indigo build 20110916-0149
Re: Eclipse does paste twice on single Ctrl+V [message #798918 is a reply to message #797430] Wed, 15 February 2012 08:20 Go to previous message
Dani Megert is currently offline Dani MegertFriend
Messages: 3802
Registered: July 2009
Senior Member
On 13.02.2012 14:30, Petr Mruzek wrote:
> Hello,
>
> please excuse my English, I'll try my best.
>
> I'm czech programmer and I use czech QWERTZ keyboard.
>
> Here is my problem:
>
> In QWERTZ, special characters as "<", ">", "[", "{", "@" etc. are only
> available by their right Alt+ shortcuts.
> For example "<" is RightAlt+,
> "@" is RightAlt+V
> ..
>
> I use these shortcuts for a long time so it would be terrifying to
> start with using EN keyboard.
>
> When I use RightAlt+, each editor take me '<' character. But in
> Eclipse I get ",<".
> I don't know how is this possible. The worst thing is, that when I
> wait some time, this behavior dissapear for moment and after short
> writing it came back.
>
> Next issue is that Numeric Pad writes double digits. I push '8' and I
> get "88".
>
> All of that I could suffer, but Double copy issue i can't.
>
> Ctrl+C works normally (copied "some string")
> Ctrl+V gives me sometimes "some stringsome string".
> Context menu and Paste selection gives me normal result ("some string").
>
> In Preferences when I want to set shortcut, I push it and it appears
> twice in dialog.
>
> What can I do to stop this?
If you use Dragon Actually Speaking, then this is not an Eclipse
specific bug (see https://bugs.eclipse.org/370362). If not, please file
a bug report against Platform SWT.

Dani
>
> OS: Windows 7 Professional SP1
> Eclipse Indigo build 20110916-0149
Previous Topic:communicate with Visio from a Java/SWT application
Next Topic:JDK in Eclipse
Goto Forum:
  


Current Time: Wed Jun 16 15:29:44 GMT 2021

Powered by FUDForum. Page generated in 0.02629 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top