Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Require-Bundle(declaring a dependency from a plugin to a bundle without loading the plugin in case of missing bundle ?)
Require-Bundle [message #793760] Wed, 08 February 2012 14:31 Go to next message
Gidi Gal is currently offline Gidi GalFriend
Messages: 42
Registered: July 2009
Member
Hello to the forum members,

I am developing an Eclipse plugin. I am using Require-Bundle in order to declare dependency to a bundle from one of Eclipse projects. This bundle is not part of the basic Eclipse distribution.
Is there a way to state that in case this required bundle is not found in Eclipse installation, my plugin will not be loaded ? I see that in such case an exception of the type org.osgi.framework.BundleException is thrown.

Many thanks,
Gidi
Re: Require-Bundle [message #794625 is a reply to message #793760] Thu, 09 February 2012 14:18 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4065
Registered: July 2009
Senior Member

This is part of the OSGI spec. Unmet dependencies will prevent your bundle from starting. It already works this way.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:embedded method
Next Topic:Thinking in Java Book problems
Goto Forum:
  


Current Time: Mon Jun 21 02:35:40 GMT 2021

Powered by FUDForum. Page generated in 0.03138 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top