Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » No drag handle for WorkbenchWindowControlContribution in trim area
No drag handle for WorkbenchWindowControlContribution in trim area [message #793628] Wed, 08 February 2012 11:12 Go to next message
Michael Bartl is currently offline Michael BartlFriend
Messages: 14
Registered: July 2009
Junior Member
Below is the a reduced code snippet from my contribution to the trim area.
Some of my users report that they can't see the drag handle and it seems to me that those are only MacOS users. Works on WinXP and Win7.

Any idea what needs to be changed so that it works on all platforms?

protected Control createControl(Composite parent)
{
// Create a composite to place the label in
Composite comp = new Composite(parent, SWT.NONE);

// Give some room around the control
GridLayout layout = new GridLayout(2, false);
layout.horizontalSpacing = 2;
layout.marginTop = 2;
layout.marginHeight = 0;
comp.setLayout(layout);

// Create a label for the trim.
label = new Label(comp, SWT.CENTER);
GridData labelGridData = new GridData(GridData.FILL_HORIZONTAL);
labelGridData.verticalAlignment = SWT.CENTER;
label.setLayoutData(labelGridData);
label.setText(" Command mode: ");
text = new Text(comp, SWT.SINGLE | SWT.BORDER | SWT.H_SCROLL);
text.setLayoutData(new GridData(GridData.FILL_BOTH));
text.setText("-------------------------------");
return comp;
}

Thanks,
Michael Bartl
Re: No drag handle for WorkbenchWindowControlContribution in trim area [message #808430 is a reply to message #793628] Mon, 27 February 2012 19:36 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Please open a bug at https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform&component=UI

It might be a platform limitation.

PW


Previous Topic:Setting Workspace Location
Next Topic:how to load external xml file without using eclipse registry
Goto Forum:
  


Current Time: Fri Nov 27 09:35:47 GMT 2020

Powered by FUDForum. Page generated in 0.01390 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top