Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » need latest runtime for web viewer(app uses web viewer but lacks latest runtime - reports fail)
need latest runtime for web viewer [message #790144] Fri, 03 February 2012 22:00 Go to next message
ron righter is currently offline ron righterFriend
Messages: 6
Registered: July 2009
Junior Member
Hi,
We are migrating a legacy application to the newest version of Eclipse and Birt (3.7.1) and Flashbuilder 4.6 from an Eclispe 2x, Birt 2X and Flexbuilder 3X development environment. The application runs BIRT reports from a Flex front end by constructing the URL to run the report in the BIRT Web Viewer. We use Tomcat.
New reports built in the new development environment are getting the error message "invalid design file". (see the stack trace below). However, the new reports run successfully inside Eclipse, from the Report Design perspective, when we select the menu choice "View Report in Web Viewer". I believe this uses the Web Viewer installed as a plug in with Eclipse.
Reports developed in the old development environment still run successfully.
It appears the reports that don't run have been built with a new Report Designer, but are running inside an outdated runtime environment. This sound like the post of 01/03/2010 - message # 774239. However, the answer there involved upgrading the Report Engine. I believe our app uses the Web Viewer, and not Report Engine (we are not calling our reports from a Java app).
We are not certain just what is required to upgrade our runtime to make our new reports run successfully. Must we upgrade the Report Engine, the Web Viewer, or both?

Can you please advise?

Thanks
Ron Righter
ron.righter@umontana.edu

Feb 4, 2012 12:33:05 AM org.eclipse.birt.report.engine.api.impl.ReportEngineHelper openReportDesign
SEVERE: invalid design file file:/C:/workspace/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/brp/reports/mgDised.rptdesign
org.eclipse.birt.report.exception.ViewerException: There is no report design object available.
at org.eclipse.birt.report.context.ViewerAttributeBean.__init(ViewerAttributeBean.java:233)
at org.eclipse.birt.report.context.BaseAttributeBean.init(BaseAttributeBean.java:233)
at org.eclipse.birt.report.context.ViewerAttributeBean.<init>(ViewerAttributeBean.java:116)
at org.eclipse.birt.report.context.BirtContext.__init(BirtContext.java:44)
at org.eclipse.birt.report.context.BaseContext.<init>(BaseContext.java:69)
at org.eclipse.birt.report.context.BirtContext.<init>(BirtContext.java:30)
at org.eclipse.birt.report.servlet.ViewerServlet.__getContext(ViewerServlet.java:150)
at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.doGet(BirtSoapMessageDispatcherServlet.java:151)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.service(BirtSoapMessageDispatcherServlet.java:122)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerFilter.java:68)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:378)
at org.springframework.security.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:109)
at org.springframework.security.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:83)
at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
at org.springframework.security.ui.SessionFixationProtectionFilter.doFilterHttp(SessionFixationProtectionFilter.java:67)
at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
at org.springframework.security.ui.ExceptionTranslationFilter.doFilterHttp(ExceptionTranslationFilter.java:101)
at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
at org.springframework.security.wrapper.SecurityContextHolderAwareRequestFilter.doFilterHttp(SecurityContextHolderAwareRequestFilter.java:91)
at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
at org.springframework.security.ui.AbstractProcessingFilter.doFilterHttp(AbstractProcessingFilter.java:278)
at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
at org.springframework.security.ui.logout.LogoutFilter.doFilterHttp(LogoutFilter.java:89)
at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
at org.springframework.security.context.HttpSessionContextIntegrationFilter.doFilterHttp(HttpSessionContextIntegrationFilter.java:235)
at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
at org.springframework.security.util.FilterChainProxy.doFilter(FilterChainProxy.java:175)
at org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:236)
at org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:167)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
at java.lang.Thread.run(Thread.java:619)
Re: need latest runtime for web viewer [message #792327 is a reply to message #790144] Mon, 06 February 2012 22:13 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

It looks like you only need to upgrade your deployed viewer which should
be in your tomcat instance.

Jason

On 2/3/2012 5:00 PM, ron righter wrote:
> Hi,
> We are migrating a legacy application to the newest version of Eclipse
> and Birt (3.7.1) and Flashbuilder 4.6 from an Eclispe 2x, Birt 2X and
> Flexbuilder 3X development environment. The application runs BIRT
> reports from a Flex front end by constructing the URL to run the report
> in the BIRT Web Viewer. We use Tomcat.
> New reports built in the new development environment are getting the
> error message "invalid design file". (see the stack trace below).
> However, the new reports run successfully inside Eclipse, from the
> Report Design perspective, when we select the menu choice "View Report
> in Web Viewer". I believe this uses the Web Viewer installed as a plug
> in with Eclipse.
> Reports developed in the old development environment still run
> successfully. It appears the reports that don't run have been built with
> a new Report Designer, but are running inside an outdated runtime
> environment. This sound like the post of 01/03/2010 - message # 774239.
> However, the answer there involved upgrading the Report Engine. I
> believe our app uses the Web Viewer, and not Report Engine (we are not
> calling our reports from a Java app).
> We are not certain just what is required to upgrade our runtime to make
> our new reports run successfully. Must we upgrade the Report Engine, the
> Web Viewer, or both?
> Can you please advise?
>
> Thanks
> Ron Righter
> mailto:ron.righter@umontana.edu
>
> Feb 4, 2012 12:33:05 AM
> org.eclipse.birt.report.engine.api.impl.ReportEngineHelper openReportDesign
> SEVERE: invalid design file
> file:/C:/workspace/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/brp/reports/mgDised.rptdesign
>
> org.eclipse.birt.report.exception.ViewerException: There is no report
> design object available.
> at
> org.eclipse.birt.report.context.ViewerAttributeBean.__init(ViewerAttributeBean.java:233)
>
> at
> org.eclipse.birt.report.context.BaseAttributeBean.init(BaseAttributeBean.java:233)
>
> at
> org.eclipse.birt.report.context.ViewerAttributeBean.<init>(ViewerAttributeBean.java:116)
>
> at org.eclipse.birt.report.context.BirtContext.__init(BirtContext.java:44)
> at org.eclipse.birt.report.context.BaseContext.<init>(BaseContext.java:69)
> at org.eclipse.birt.report.context.BirtContext.<init>(BirtContext.java:30)
> at
> org.eclipse.birt.report.servlet.ViewerServlet.__getContext(ViewerServlet.java:150)
>
> at
> org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.doGet(BirtSoapMessageDispatcherServlet.java:151)
>
> at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
> at
> org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
>
> at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
> at
> org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.service(BirtSoapMessageDispatcherServlet.java:122)
>
> at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
>
> at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
>
> at
> org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerFilter.java:68)
> at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
>
> at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
>
> at
> org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:378)
>
> at
> org.springframework.security.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:109)
>
> at
> org.springframework.security.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:83)
>
> at
> org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
>
> at
> org.springframework.security.ui.SessionFixationProtectionFilter.doFilterHttp(SessionFixationProtectionFilter.java:67)
>
> at
> org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
>
> at
> org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
>
> at
> org.springframework.security.ui.ExceptionTranslationFilter.doFilterHttp(ExceptionTranslationFilter.java:101)
>
> at
> org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
>
> at
> org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
>
> at
> org.springframework.security.wrapper.SecurityContextHolderAwareRequestFilter.doFilterHttp(SecurityContextHolderAwareRequestFilter.java:91)
>
> at
> org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
>
> at
> org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
>
> at
> org.springframework.security.ui.AbstractProcessingFilter.doFilterHttp(AbstractProcessingFilter.java:278)
>
> at
> org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
>
> at
> org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
>
> at
> org.springframework.security.ui.logout.LogoutFilter.doFilterHttp(LogoutFilter.java:89)
>
> at
> org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
>
> at
> org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
>
> at
> org.springframework.security.context.HttpSessionContextIntegrationFilter.doFilterHttp(HttpSessionContextIntegrationFilter.java:235)
>
> at
> org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
>
> at
> org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
>
> at
> org.springframework.security.util.FilterChainProxy.doFilter(FilterChainProxy.java:175)
>
> at
> org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:236)
>
> at
> org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:167)
>
> at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
>
> at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
>
> at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
>
> at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
>
> at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
>
> at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
>
> at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
>
> at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
> at
> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
> at
> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
>
> at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
> at java.lang.Thread.run(Thread.java:619)
>
Re: need latest runtime for web viewer [message #792376 is a reply to message #790144] Mon, 06 February 2012 23:39 Go to previous messageGo to next message
ron righter is currently offline ron righterFriend
Messages: 6
Registered: July 2009
Junior Member
Jason,
Thanks for your reply. The issue is that we have never deployed ReportViewer on tomcat. Instead we simply compose a url in our Action Script code (Flex):

"<protocol>://<servername>/<appname>/frameset?__report=reports/<reportname> and parameters".

The command to launch the url is:
// This method of opening window gets around popup blockers
ExternalInterface.call("window.open", lookupBaseURL() + path, "_blank", "scrollbars,resizable");
(ExternalInterface is defined in flash.external.ExternalInterface)

This is one example call as it appears at the top of the window that displays the report:
"http:server1.umt.edu/infoGriz/frameset?_report=reports/hrStuEmpAct&StartDate=01-FEB-2012".

We have a folder in our Eclipse project under WebContent/WEB-INF/webcontent called "birt" which has the same layout and (it appears) content as one of the folders found in the Eclipse Report Viewer plugin org.eclipse.birt.report.viewer_3.7.1.v20110905). Perhaps this is how we are able
to call Report Viewer without deploying it to tomcat? Maybe this is where we need to
install the latest ReportViewer code.

Thanks for your help,
Ron Righter
ron.righter@umontana.edu
Re: need latest runtime for web viewer [message #793145 is a reply to message #792376] Tue, 07 February 2012 20:30 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Maybe so. What is this server?
http:server1.umt.edu/infoGriz . That appears to be the app that needs
changing. Is it deployed?

Jason


On 2/6/2012 6:39 PM, ron righter wrote:
> Jason,
> Thanks for your reply. The issue is that we have never deployed
> ReportViewer on tomcat. Instead we simply compose a url in our Action
> Script code (Flex):
>
> "<protocol>://<servername>/<appname>/frameset?__report=reports/<reportname>
> and parameters".
>
> The command to launch the url is:
> // This method of opening window gets around popup blockers
> ExternalInterface.call("window.open", lookupBaseURL() + path, "_blank",
> "scrollbars,resizable");
> (ExternalInterface is defined in flash.external.ExternalInterface)
>
> This is one example call as it appears at the top of the window that
> displays the report:
> "http:server1.umt.edu/infoGriz/frameset?_report=reports/hrStuEmpAct&StartDate=01-FEB-2012".
>
>
> We have a folder in our Eclipse project under
> WebContent/WEB-INF/webcontent called "birt" which has the same layout
> and (it appears) content as one of the folders found in the Eclipse
> Report Viewer plugin org.eclipse.birt.report.viewer_3.7.1.v20110905).
> Perhaps this is how we are able
> to call Report Viewer without deploying it to tomcat? Maybe this is
> where we need to
> install the latest ReportViewer code.
>
> Thanks for your help,
> Ron Righter
> mailto:ron.righter@umontana.edu
Re: need latest runtime for web viewer [message #793210 is a reply to message #793145] Tue, 07 February 2012 22:13 Go to previous messageGo to next message
ron righter is currently offline ron righterFriend
Messages: 6
Registered: July 2009
Junior Member
Jason,
The actual name of the application is infoGriz, and yes it is deployed on Tomcat 6.0.18. Actually "server1.umt.edu" is just a made-up name for the server. Exactly what that name is depends on whether this is our dev/test/prod deployment. So while it is true that we don't have BIRT Report Viewer per se deployed on Tomcat, it appears that it may be contained in our application which in turn, is deployed on Tomcat. Would it help to see our web.xml file?
Thanks,
Ron
Re: need latest runtime for web viewer [message #793386 is a reply to message #793210] Wed, 08 February 2012 04:23 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Sure can you post it?

Jason

On 2/7/2012 5:13 PM, ron righter wrote:
> Jason,
> The actual name of the application is infoGriz, and yes it is deployed
> on Tomcat 6.0.18. Actually "server1.umt.edu" is just a made-up name for
> the server. Exactly what that name is depends on whether this is our
> dev/test/prod deployment. So while it is true that we don't have BIRT
> Report Viewer per se deployed on Tomcat, it appears that it may be
> contained in our application which in turn, is deployed on Tomcat. Would
> it help to see our web.xml file?
> Thanks,
> Ron
>
Re: need latest runtime for web viewer [message #793791 is a reply to message #793386] Wed, 08 February 2012 15:19 Go to previous messageGo to next message
ron righter is currently offline ron righterFriend
Messages: 6
Registered: July 2009
Junior Member
Jason,
Here's our web.xml.
Ron
  • Attachment: web.xml
    (Size: 8.38KB, Downloaded 444 times)
Re: need latest runtime for web viewer [message #794834 is a reply to message #793791] Thu, 09 February 2012 19:08 Go to previous messageGo to next message
ron righter is currently offline ron righterFriend
Messages: 6
Registered: July 2009
Junior Member
Jason,
We have tried a few things in the last day. First though, we routinely see an error on our Eclipse console when we atart tomcat:

"Exception sending context initialized event to listener instance of class org.eclipse.birt.report.listener.ViewerServletContextListener"

The full stack trace is at 2 below with the above message 5 or 6 lines down.

Secondly, we began to think that since we are making a big leap in Birt releases (2x to 3.7), that our app may contain jars that were formerly part of Birt, but that are no longer needed (perhaps all their contents are now deployed in the jar "org.eclpse.birt.runtime_3.7.1). So we deleted the jars listed below from our apps lib folder. This seemed to make no difference. Both before and after deleting these jars, we get the ViewerServletContextListener error described above.

Thanks again for you generous help,
Ron Righter

1) deleted jars
chartengineapi.jar
coreapi.jar
crosstabcorapi.jar
dataadapterapi.jar
dataaggregationapi.jar
dataextraction.jar
detapi.jar
engineapi.jar
modelapi.jar
modelodaapi.jar
odadesignapi.jar

2) stack trace for error
Feb 9, 2012 9:08:29 AM org.apache.catalina.core.ApplicationContext log
INFO: Set web app root system property: 'webapp.root' = [C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp1\wtpwebapps\brp\]
Feb 9, 2012 9:08:29 AM org.apache.catalina.core.ApplicationContext log
INFO: Initializing log4j from [C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp1\wtpwebapps\brp\WEB-INF\classes\log4j.properties]
Feb 9, 2012 9:08:31 AM org.apache.catalina.core.StandardContext listenerStart

SEVERE: Exception sending context initialized event to listener instance of class org.eclipse.birt.report.listener.ViewerServletContextListener
java.lang.NullPointerException
at org.eclipse.birt.report.engine.api.impl.ReportEngine$EngineExtensionManager.<init>(ReportEngine.java:819)
at org.eclipse.birt.report.engine.api.impl.ReportEngine.<init>(ReportEngine.java:111)
at org.eclipse.birt.report.engine.api.impl.ReportEngineFactory$1.run(ReportEngineFactory.java:18)
at org.eclipse.birt.report.engine.api.impl.ReportEngineFactory$1.run(ReportEngineFactory.java:1)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.birt.report.engine.api.impl.ReportEngineFactory.createReportEngine(ReportEngineFactory.java:14)
at org.eclipse.birt.report.service.ReportEngineService.setEngineContext(ReportEngineService.java:336)
at org.eclipse.birt.report.service.BirtViewerReportService.setContext(BirtViewerReportService.java:1022)
at org.eclipse.birt.report.listener.ViewerServletContextListener.contextInitialized(ViewerServletContextListener.java:62)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3843)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4342)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
at org.apache.catalina.core.StandardService.start(StandardService.java:516)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Feb 9, 2012 9:08:31 AM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Re: need latest runtime for web viewer [message #795533 is a reply to message #794834] Fri, 10 February 2012 15:26 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Ron,

Since you went to 3.7.1 did you remove the platform directory? You
should have all the jars in the 3.7.1 runtime
download/WebViewerExample/Web-inf/lib directory in in your apps
web-inf/lib . What I would suggest doing is removing all the ones that
came in your 2x birt install and adding the ones from the 3.7.1 download.

Jason


On 2/9/2012 2:08 PM, ron righter wrote:
> Jason,
> We have tried a few things in the last day. First though, we routinely
> see an error on our Eclipse console when we atart tomcat:
>
> "Exception sending context initialized event to listener instance of
> class org.eclipse.birt.report.listener.ViewerServletContextListener"
>
> The full stack trace is at 2 below with the above message 5 or 6 lines
> down.
>
> Secondly, we began to think that since we are making a big leap in Birt
> releases (2x to 3.7), that our app may contain jars that were formerly
> part of Birt, but that are no longer needed (perhaps all their contents
> are now deployed in the jar "org.eclpse.birt.runtime_3.7.1). So we
> deleted the jars listed below from our apps lib folder. This seemed to
> make no difference. Both before and after deleting these jars, we get
> the ViewerServletContextListener error described above.
>
> Thanks again for you generous help,
> Ron Righter
>
> 1) deleted jars
> chartengineapi.jar
> coreapi.jar
> crosstabcorapi.jar
> dataadapterapi.jar
> dataaggregationapi.jar
> dataextraction.jar
> detapi.jar
> engineapi.jar
> modelapi.jar
> modelodaapi.jar
> odadesignapi.jar
>
> 2) stack trace for error
> Feb 9, 2012 9:08:29 AM org.apache.catalina.core.ApplicationContext log
> INFO: Set web app root system property: 'webapp.root' =
> [C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp1\wtpwebapps\brp\]
>
> Feb 9, 2012 9:08:29 AM org.apache.catalina.core.ApplicationContext log
> INFO: Initializing log4j from
> [C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp1\wtpwebapps\brp\WEB-INF\classes\log4j.properties]
>
> Feb 9, 2012 9:08:31 AM org.apache.catalina.core.StandardContext
> listenerStart
>
> SEVERE: Exception sending context initialized event to listener instance
> of class org.eclipse.birt.report.listener.ViewerServletContextListener
> java.lang.NullPointerException
> at
> org.eclipse.birt.report.engine.api.impl.ReportEngine$EngineExtensionManager.<init>(ReportEngine.java:819)
>
> at
> org.eclipse.birt.report.engine.api.impl.ReportEngine.<init>(ReportEngine.java:111)
>
> at
> org.eclipse.birt.report.engine.api.impl.ReportEngineFactory$1.run(ReportEngineFactory.java:18)
>
> at
> org.eclipse.birt.report.engine.api.impl.ReportEngineFactory$1.run(ReportEngineFactory.java:1)
>
> at java.security.AccessController.doPrivileged(Native Method)
> at
> org.eclipse.birt.report.engine.api.impl.ReportEngineFactory.createReportEngine(ReportEngineFactory.java:14)
>
> at
> org.eclipse.birt.report.service.ReportEngineService.setEngineContext(ReportEngineService.java:336)
>
> at
> org.eclipse.birt.report.service.BirtViewerReportService.setContext(BirtViewerReportService.java:1022)
>
> at
> org.eclipse.birt.report.listener.ViewerServletContextListener.contextInitialized(ViewerServletContextListener.java:62)
>
> at
> org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3843)
>
> at
> org.apache.catalina.core.StandardContext.start(StandardContext.java:4342)
> at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
> at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
> at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
> at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
> at org.apache.catalina.core.StandardService.start(StandardService.java:516)
> at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
> at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
> at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
> Feb 9, 2012 9:08:31 AM org.apache.catalina.core.StandardContext start
> SEVERE: Error listenerStart
Re: need latest runtime for web viewer [message #795545 is a reply to message #795533] Fri, 10 February 2012 15:46 Go to previous messageGo to next message
ron righter is currently offline ron righterFriend
Messages: 6
Registered: July 2009
Junior Member
Jason,
Yes - we did remove the platform folder since (we understand) it's part of the old OSGI deployment for Viewer. We also replaced the folder WebContent/webcontent/birt with the one in the 3.7.1 runtime WebViewerExample, and replaced the birt.tld in WEB-INF/tlds with the new one. We then replaced viewer.properties in WEB-INF with the new one (since there are several new property settings) and modified web.xml to include:

<context-param>
<param-name>URL_REPORT_PATH_POLICY</param-name>
<param-value>domain</param-value>
</context-param>

The error we get now, after removing the platform folder is below. Something old from the previous deployment is apparently expecting the OSGI code. Is this likely in a jar from the previous install? I know you suggested removing old jars from WEB-INFO/lib, but as I said in my previous post, we removed 11 Birt jar files from WEB-INF/lib. What else can there be?

Thanks again,
Ron

org.eclipse.birt.core.exception.BirtException: error.CannotStartupOSGIPlatform
at org.eclipse.birt.core.framework.Platform.startup(Platform.java:81)
at org.eclipse.birt.report.service.ReportEngineService.setEngineContext(ReportEngineService.java:328)
at org.eclipse.birt.report.service.BirtViewerReportService.setContext(BirtViewerReportService.java:1022)
at org.eclipse.birt.report.listener.ViewerServletContextListener.contextInitialized(ViewerServletContextListener.java:62)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3843)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4342)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
at org.apache.catalina.core.StandardService.start(StandardService.java:516)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Caused by: org.eclipse.birt.core.framework.FrameworkException
at org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OSGILauncher.java:90)
at org.eclipse.birt.core.framework.Platform.startup(Platform.java:75)
... 18 more
Caused by: java.security.PrivilegedActionException: org.eclipse.birt.core.framework.FrameworkException: Could not find the Framework - org.eclipse.osgi in path C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp1\wtpwebapps\brp\WEB-INF\platform\plugins
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OSGILauncher.java:75)
... 19 more
Caused by: org.eclipse.birt.core.framework.FrameworkException: Could not find the Framework - org.eclipse.osgi in path C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp1\wtpwebapps\brp\WEB-INF\platform\plugins
at org.eclipse.birt.core.framework.osgi.OSGILauncher.doStartup(OSGILauncher.java:123)
at org.eclipse.birt.core.framework.osgi.OSGILauncher.access$0(OSGILauncher.java:94)
at org.eclipse.birt.core.framework.osgi.OSGILauncher$1.run(OSGILauncher.java:79)
... 21 more
Re: need latest runtime for web viewer [message #795567 is a reply to message #795545] Fri, 10 February 2012 16:02 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Are you certain you removed all the earlier versions of the
BIRT/osgi/dtp jars from the web-inf/lib?

Jason

On 2/10/2012 10:46 AM, ron righter wrote:
> Jason,
> Yes - we did remove the platform folder since (we understand) it's part
> of the old OSGI deployment for Viewer. We also replaced the folder
> WebContent/webcontent/birt with the one in the 3.7.1 runtime
> WebViewerExample, and replaced the birt.tld in WEB-INF/tlds with the new
> one. We then replaced viewer.properties in WEB-INF with the new one
> (since there are several new property settings) and modified web.xml to
> include:
>
> <context-param>
> <param-name>URL_REPORT_PATH_POLICY</param-name>
> <param-value>domain</param-value>
> </context-param>
>
> The error we get now, after removing the platform folder is below.
> Something old from the previous deployment is apparently expecting the
> OSGI code. Is this likely in a jar from the previous install? I know you
> suggested removing old jars from WEB-INFO/lib, but as I said in my
> previous post, we removed 11 Birt jar files from WEB-INF/lib. What else
> can there be?
>
> Thanks again,
> Ron
>
> org.eclipse.birt.core.exception.BirtException:
> error.CannotStartupOSGIPlatform
> at org.eclipse.birt.core.framework.Platform.startup(Platform.java:81)
> at
> org.eclipse.birt.report.service.ReportEngineService.setEngineContext(ReportEngineService.java:328)
>
> at
> org.eclipse.birt.report.service.BirtViewerReportService.setContext(BirtViewerReportService.java:1022)
>
> at
> org.eclipse.birt.report.listener.ViewerServletContextListener.contextInitialized(ViewerServletContextListener.java:62)
>
> at
> org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3843)
>
> at
> org.apache.catalina.core.StandardContext.start(StandardContext.java:4342)
> at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
> at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
> at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
> at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
> at org.apache.catalina.core.StandardService.start(StandardService.java:516)
> at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
> at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
> at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
> Caused by: org.eclipse.birt.core.framework.FrameworkException
> at
> org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OSGILauncher.java:90)
>
> at org.eclipse.birt.core.framework.Platform.startup(Platform.java:75)
> ... 18 more
> Caused by: java.security.PrivilegedActionException:
> org.eclipse.birt.core.framework.FrameworkException: Could not find the
> Framework - org.eclipse.osgi in path
> C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp1\wtpwebapps\brp\WEB-INF\platform\plugins
>
> at java.security.AccessController.doPrivileged(Native Method)
> at
> org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OSGILauncher.java:75)
>
> ... 19 more
> Caused by: org.eclipse.birt.core.framework.FrameworkException: Could not
> find the Framework - org.eclipse.osgi in path
> C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp1\wtpwebapps\brp\WEB-INF\platform\plugins
>
> at
> org.eclipse.birt.core.framework.osgi.OSGILauncher.doStartup(OSGILauncher.java:123)
>
> at
> org.eclipse.birt.core.framework.osgi.OSGILauncher.access$0(OSGILauncher.java:94)
>
> at
> org.eclipse.birt.core.framework.osgi.OSGILauncher$1.run(OSGILauncher.java:79)
>
> ... 21 more
Previous Topic:birt
Next Topic:Button on report
Goto Forum:
  


Current Time: Sun Nov 28 00:54:20 GMT 2021

Powered by FUDForum. Page generated in 0.02448 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top