Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Stereotype Icon problem
Stereotype Icon problem [message #770911] Sun, 25 December 2011 19:29
Eclipse GuestFriend
Messages: 93
Registered: February 2013
Location: Vienna
Member
Hello! I've got a problem with icon for stereotype.

I use Papyrus Editor in new Topcased 5.1 (Eclipse Indigo Version: 3.7.1)

For example, I've got metaclass <Actor> and stereotype <External System> that extends metaclass.

I want to use instead of typical "stick man" notation for actor my own picture (icon).
So, i add my icon with "shape kind". It seems like everything is ok, but when i try to validate my profile there is an error:
The opposite features 'owner' of '<Image>' and 'ownedElement' of '<Stereotype> External System' do not refer to each other.

Please help me to understand what is wrong?

And if i ignore that problem, when i try to apply my stereotype to element a lot of errors occur. Among them:
NullPointerException: null
at:org.eclipse.papyrus.sysml.modelexplorer.query.GetImageQuery.evaluate(GetImageQuery.java:24)

and so on..

If someone knows the solution I'll be very grateful to you!
Previous Topic:Aggregation in Papyrus
Next Topic:Disposing editor Parts on Close
Goto Forum:
  


Current Time: Wed Sep 30 22:10:19 GMT 2020

Powered by FUDForum. Page generated in 0.05930 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top