Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Debug launch problem "Program not recognized executable"(Eclipse CDT on Mac OS Lion, Debug execution problem)
Debug launch problem "Program not recognized executable" [message #759145] Sat, 26 November 2011 22:04 Go to next message
Dan  is currently offline Dan Friend
Messages: 2
Registered: November 2011
Junior Member
I am new to Eclipse and was not sure if this question belongs here (Newcomers) or in the CDT forum. I am trying here first.

I am running Mac OS Lion (10.7.2) and have downloaded and installed XCode 4.1 and Eclipse Indigo.

I have a straightforward C++ program. The program compiles and executes correctly in Eclipse. But when I go to Debug, it won't start and I get this message, "Launching <program> Debug has encountered a problem, Program is not a recognized executable." When I click "Details" I get the "not an executable" message four times.

In the Project properties / settings, it is pointed to GDB and to the right executable. I can launch GDB with the program executable from a terminal window and it works fine.

I've scoured the internet and Bugzilla, but I've only seen one other instance of this problem and the solution given didn't work for me (and was for Windows anyhow).

Any suggestions are greatly appreciated!
Re: Debug launch problem &quot;Program not recognized executable&quot; [message #759148 is a reply to message #759145] Sat, 26 November 2011 22:19 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2011.11.26 15:04, Dan wrote:
> I am new to Eclipse and was not sure if this question belongs here
> (Newcomers) or in the CDT forum. I am trying here first.
>
> I am running Mac OS Lion (10.7.2) and have downloaded and installed
> XCode 4.1 and Eclipse Indigo.
>
> I have a straightforward C++ program. The program compiles and executes
> correctly in Eclipse. But when I go to Debug, it won't start and I get
> this message, "Launching <program> Debug has encountered a problem,
> Program is not a recognized executable." When I click "Details" I get
> the "not an executable" message four times.
>
> In the Project properties / settings, it is pointed to GDB and to the
> right executable. I can launch GDB with the program executable from a
> terminal window and it works fine.
>
> I've scoured the internet and Bugzilla, but I've only seen one other
> instance of this problem and the solution given didn't work for me (and
> was for Windows anyhow).
>
> Any suggestions are greatly appreciated!

Likely more of an Eclipse CDT question.
Previous Topic:well I want include and JAVASCRIPT rather the standalone, what do
Next Topic:Looking for a Database Web Application Tutorial
Goto Forum:
  


Current Time: Sat Jun 19 19:59:54 GMT 2021

Powered by FUDForum. Page generated in 0.03223 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top