Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » [eclipse] Problem upgrading to xtext 2.1.1
[eclipse] Problem upgrading to xtext 2.1.1 [message #759115] Sat, 26 November 2011 14:09 Go to next message
Goran   is currently offline Goran Friend
Messages: 45
Registered: November 2011
Member
I have a strange problem when trying to upgrade to xtext 2.1.1 using the update site

http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/

With a fresh "Xtext 2.1.0 Distribution (Indigo)" install in Ubuntu 64bit I get the following error when doing an update using the update site above:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Xtext SDK 2.1.1.v201111141332 (org.eclipse.xtext.sdk.feature.group 2.1.1.v201111141332)
  Software currently installed: Shared profile 1.0.0.1320837589035 (SharedProfile_SDKProfile 1.0.0.1320837589035)
  Only one of the following can be installed at once: 
    Xtext UI Shared 1.0.2.v201102150722 (org.eclipse.xtext.ui.shared 1.0.2.v201102150722)
    Xtext UI Shared 2.1.1.v201111141332 (org.eclipse.xtext.ui.shared 2.1.1.v201111141332)
    Xtext UI Shared 2.1.0.v201111010612 (org.eclipse.xtext.ui.shared 2.1.0.v201111010612)
    Xtext UI Shared 2.0.0.v201106070531 (org.eclipse.xtext.ui.shared 2.0.0.v201106070531)
  Cannot satisfy dependency:
    From: Shared profile 1.0.0.1320837589035 (SharedProfile_SDKProfile 1.0.0.1320837589035)
    To: org.eclipse.xtext.ui.shared [2.1.0.v201111010612]
  Cannot satisfy dependency:
    From: Xtext SDK 2.1.1.v201111141332 (org.eclipse.xtext.sdk.feature.group 2.1.1.v201111141332)
    To: org.eclipse.xtext.ui.feature.group [2.1.1.v201111141332]
  Cannot satisfy dependency:
    From: Xtext UI 2.1.1.v201111141332 (org.eclipse.xtext.ui.feature.group 2.1.1.v201111141332)
    To: org.eclipse.xtext.ui.shared [2.1.1.v201111141332]


What could the problem be?

Thanks in advanced
Re: [eclipse] Problem upgrading to xtext 2.1.1 [message #759218 is a reply to message #759115] Sun, 27 November 2011 18:52 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3107
Registered: July 2009
Senior Member
Hi Goran,

how did you try to update the installation? It usually works if you
select 'Install New Software' and pick the Xtext SDK.

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com


Am 26.11.11 15:09, schrieb Goran:
> I have a strange problem when trying to upgrade to xtext 2.1.1 using the
> update site
>
> http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/
>
> With a fresh "Xtext 2.1.0 Distribution (Indigo)" install in Ubuntu 64bit
> I get the following error when doing an update using the update site above:
>
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Xtext SDK 2.1.1.v201111141332
> (org.eclipse.xtext.sdk.feature.group 2.1.1.v201111141332)
> Software currently installed: Shared profile 1.0.0.1320837589035
> (SharedProfile_SDKProfile 1.0.0.1320837589035)
> Only one of the following can be installed at once: Xtext UI Shared
> 1.0.2.v201102150722 (org.eclipse.xtext.ui.shared 1.0.2.v201102150722)
> Xtext UI Shared 2.1.1.v201111141332 (org.eclipse.xtext.ui.shared
> 2.1.1.v201111141332)
> Xtext UI Shared 2.1.0.v201111010612 (org.eclipse.xtext.ui.shared
> 2.1.0.v201111010612)
> Xtext UI Shared 2.0.0.v201106070531 (org.eclipse.xtext.ui.shared
> 2.0.0.v201106070531)
> Cannot satisfy dependency:
> From: Shared profile 1.0.0.1320837589035 (SharedProfile_SDKProfile
> 1.0.0.1320837589035)
> To: org.eclipse.xtext.ui.shared [2.1.0.v201111010612]
> Cannot satisfy dependency:
> From: Xtext SDK 2.1.1.v201111141332 (org.eclipse.xtext.sdk.feature.group
> 2.1.1.v201111141332)
> To: org.eclipse.xtext.ui.feature.group [2.1.1.v201111141332]
> Cannot satisfy dependency:
> From: Xtext UI 2.1.1.v201111141332 (org.eclipse.xtext.ui.feature.group
> 2.1.1.v201111141332)
> To: org.eclipse.xtext.ui.shared [2.1.1.v201111141332]
>
>
> What could the problem be?
>
> Thanks in advanced
Re: [eclipse] Problem upgrading to xtext 2.1.1 [message #759234 is a reply to message #759218] Sun, 27 November 2011 22:51 Go to previous messageGo to next message
Goran   is currently offline Goran Friend
Messages: 45
Registered: November 2011
Member
I also tried "Install new Software" -> Choose "TMF Xtext-2.1.1". I then get the following error:

Your original request has been modified.
  Xtext SDK will be ignored because it is already installed, and updates are not permitted.
Cannot complete the install because of a conflicting dependency.
  Software being installed: Xtext UI 2.1.1.v201111141332 (org.eclipse.xtext.ui.feature.group 2.1.1.v201111141332)
  Software currently installed: Xtext SDK 2.1.0.v201111010612 (org.eclipse.xtext.sdk.feature.group 2.1.0.v201111010612)
  Only one of the following can be installed at once: 
    Common Types Shared State 2.1.1.v201111141332 (org.eclipse.xtext.common.types.shared 2.1.1.v201111141332)
    Common Types Shared State 2.1.0.v201111010612 (org.eclipse.xtext.common.types.shared 2.1.0.v201111010612)
  Cannot satisfy dependency:
    From: Xtext SDK 2.1.0.v201111010612 (org.eclipse.xtext.sdk.feature.group 2.1.0.v201111010612)
    To: org.eclipse.xtext.ui.feature.group [2.1.0.v201111010612]
  Cannot satisfy dependency:
    From: Xtext UI 2.1.0.v201111010612 (org.eclipse.xtext.ui.feature.group 2.1.0.v201111010612)
    To: org.eclipse.xtext.common.types.shared [2.1.0.v201111010612]
  Cannot satisfy dependency:
    From: Xtext UI 2.1.1.v201111141332 (org.eclipse.xtext.ui.feature.group 2.1.1.v201111141332)
    To: org.eclipse.xtext.common.types.shared [2.1.1.v201111141332]


Remember that I get this using a fresh "Xtext 2.1.0 Distribution (Indigo)" 64 bit installation on Linux.
Re: [eclipse] Problem upgrading to xtext 2.1.1 [message #759258 is a reply to message #759234] Mon, 28 November 2011 06:39 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3107
Registered: July 2009
Senior Member
Goran,

please file a ticket.

Thanks,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 27.11.11 23:51, schrieb Goran:
> I also tried "Install new Software" -> Choose "TMF Xtext-2.1.1". I then
> get the following error:
>
>
> Your original request has been modified.
> Xtext SDK will be ignored because it is already installed, and updates
> are not permitted.
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Xtext UI 2.1.1.v201111141332
> (org.eclipse.xtext.ui.feature.group 2.1.1.v201111141332)
> Software currently installed: Xtext SDK 2.1.0.v201111010612
> (org.eclipse.xtext.sdk.feature.group 2.1.0.v201111010612)
> Only one of the following can be installed at once: Common Types Shared
> State 2.1.1.v201111141332 (org.eclipse.xtext.common.types.shared
> 2.1.1.v201111141332)
> Common Types Shared State 2.1.0.v201111010612
> (org.eclipse.xtext.common.types.shared 2.1.0.v201111010612)
> Cannot satisfy dependency:
> From: Xtext SDK 2.1.0.v201111010612 (org.eclipse.xtext.sdk.feature.group
> 2.1.0.v201111010612)
> To: org.eclipse.xtext.ui.feature.group [2.1.0.v201111010612]
> Cannot satisfy dependency:
> From: Xtext UI 2.1.0.v201111010612 (org.eclipse.xtext.ui.feature.group
> 2.1.0.v201111010612)
> To: org.eclipse.xtext.common.types.shared [2.1.0.v201111010612]
> Cannot satisfy dependency:
> From: Xtext UI 2.1.1.v201111141332 (org.eclipse.xtext.ui.feature.group
> 2.1.1.v201111141332)
> To: org.eclipse.xtext.common.types.shared [2.1.1.v201111141332]
>
>
> Remember that I get this using a fresh "Xtext 2.1.0 Distribution
> (Indigo)" 64 bit installation on Linux.
Re: [eclipse] Problem upgrading to xtext 2.1.1 [message #760005 is a reply to message #759258] Wed, 30 November 2011 21:35 Go to previous messageGo to next message
Goran   is currently offline Goran Friend
Messages: 45
Registered: November 2011
Member
It seems that this is an issue of Eclipse.
I was able to circumvent this by running the update process as administrator.
Then restart eclipse as a normal user.

See http://tinyurl.com/6kuh5ya

~ Goran

[Updated on: Wed, 30 November 2011 21:36]

Report message to a moderator

Re: [eclipse] Problem upgrading to xtext 2.1.1 [message #762010 is a reply to message #760005] Wed, 07 December 2011 12:22 Go to previous message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1762
Registered: July 2009
Location: Firenze, Italy
Senior Member
On 11/30/2011 10:35 PM, Goran wrote:
> It seems that this is an issue of Eclipse Indigo.
> I was able to circumvent this by running the update process as
> administrator.
> Then restart eclipse as a normal user.
>
> See http://tinyurl.com/6kuh5ya
>
> ~ Goran

I'm experiencing the same problem with an xtext 2.0 distribution
downloaded from itemis...

but I can't see your bug, can you please provide the complete URL?

have you managed to solve the problem?

thanks in advance
Lorenzo


Previous Topic:Where has the OnTheFlyCompiler gone?
Next Topic:Buils xtext projects issues
Goto Forum:
  


Current Time: Sun Mar 29 22:50:46 GMT 2020

Powered by FUDForum. Page generated in 0.07933 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top