Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » git pull command error
git pull command error [message #758736] Thu, 24 November 2011 12:44
dantart is currently offline dantartFriend
Messages: 1
Registered: November 2011
Junior Member
Github repo with just created with one file of one line (the minimum to do the test)

Windows 7 + Eclipse + egit.core_1.1.0.201109151100-r (we have tried also with the last nightly build)
Linux + Git (we have tried with 1.6 also)


1) Any of players create the repository with one file and one line in it. Github shows correctly the stuff.
The last commit hash is now (for example): 1

2) Linux player changes the line, commits and pushes
The last commit hash is now: 2

3) Windows player pulls ... changes the line, commits and pushes
The last commit hash is now: 3

4) Linux can't pull anymore, it appears:

error: unable to find "hash 3"
fatal: object "hash 3" not found

BUG: Since the moment Windows player pushes the first time, the Linux players can't pull anymore.

Things to have in mind:

- github shows the 3 commits correctly, the last one the number 3
- in the linux: git fsck shows nothing at all ...
- if the linux delete the repo and clone it again, it pulls correctly up to "hash 3"
- if the linux do a reset to HEAD, it responds: HEAD is now at "hash 2"

In some way, linux git knows the HEAD is "hash 3", but it can't find it.

Thank you in advance Smile
Previous Topic:Passphrase fails with egit.
Next Topic:Switching branches leaves folders that should be gone!
Goto Forum:

Current Time: Sun Sep 22 09:49:42 GMT 2019

Powered by FUDForum. Page generated in 0.02080 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top