Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse navigator opening in specific project(General)
icon5.gif  Eclipse navigator opening in specific project [message #758375] Tue, 22 November 2011 22:46 Go to next message
Justin King is currently offline Justin KingFriend
Messages: 1
Registered: November 2011
Junior Member
Hey guys,

Not specifically a newcomer question but I didn't know exactly where to file it.

I have an issue where the Navigator window opens inside a specific project when eclipse opens. This is fine as I can click 'up' and back up to the multi project level where I want to be. The problem is if the project it opens on is closed, I get stuck and I have to mess about to get back to the multi project level.

It only ever opens on one specific project, not sure why its become set to that. I'd like it to just open at the top level so I can view all my projects and go from there.

Is this a bug or do I have some strange configuration? It seems to effect other windows as well such as 'WO Explorer' from WOLips.

Thanks in advance.
Re: Eclipse navigator opening in specific project [message #758574 is a reply to message #758375] Wed, 23 November 2011 17:52 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
On 11/22/11 5:46 PM, Justin King wrote:
> Hey guys,
>
> Not specifically a newcomer question but I didn't know exactly where to
> file it.
> I have an issue where the Navigator window opens inside a specific
> project when eclipse opens. This is fine as I can click 'up' and back up
> to the multi project level where I want to be. The problem is if the
> project it opens on is closed, I get stuck and I have to mess about to
> get back to the multi project level.
>
> It only ever opens on one specific project, not sure why its become set
> to that. I'd like it to just open at the top level so I can view all my
> projects and go from there.
> Is this a bug or do I have some strange configuration? It seems to
> effect other windows as well such as 'WO Explorer' from WOLips.
> Thanks in advance.

That's very odd behavior that I've never seen. One "grasping at straws"
suggestion: Use Window > Reset Perspective... to try to get it back to a
"standard state" that doesn't always open inside a project.

Eric
Re: Eclipse navigator opening in specific project [message #758599 is a reply to message #758574] Wed, 23 November 2011 20:14 Go to previous message
David Wegener is currently offline David WegenerFriend
Messages: 1441
Registered: July 2009
Senior Member
You may have selected the Go Into option on the context menu. This switches the root of the view to the element that Go Into is performed on. There are arrow icons at the top of the view. The one pointing left takes you back a level. If it is highlighted, try clicking that to see if it solves your problem.
Previous Topic:Build hangs on synchronized fortran job
Next Topic:How to make eclipse search stop closing windows?
Goto Forum:
  


Current Time: Tue Jun 22 02:51:02 GMT 2021

Powered by FUDForum. Page generated in 0.02884 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top