Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » [SysML] SI Units Library & Import(Is the library included and how to import it?)
[SysML] SI Units Library & Import [message #755611] Wed, 09 November 2011 01:12 Go to next message
Horacio Hoyos is currently offline Horacio HoyosFriend
Messages: 210
Registered: October 2009
Location: UK
Senior Member

Hello,

Does papyrus packs the SI Units library? If so, how can I add it to my model. If not, is there a way to create libraries and use them in your models?

Thanks,

Horacio


Horacio Hoyos Rodriguez
Epsilon Committer
Research Assistant
University Of York
Re: [SysML] SI Units Library & Import [message #755961 is a reply to message #755611] Thu, 10 November 2011 10:38 Go to previous messageGo to next message
Carlos Gomez is currently offline Carlos GomezFriend
Messages: 63
Registered: October 2010
Member
Hello Horacio,

If I'm not wrong, the only library that has SI Units is MARTE. So, You can import this library to your model folling this steps:

1. Click right on your model package and select import->import registered package
2. Choose Marte_Library and OK
3. On the new window, select BasicNFP_Types folder and OK

And that's all. You have the SI basic Types in your model.

If you want to use it, I suggest to see the MARTE standard, section NFP (Non-Functional Properties).

If you want to use SysML library, I think that you have to create it. I suggest you to use MARTE Units specification, it is better defined.

I hope this guide can help you.

Cordially,

CarlosG

Re: [SysML] SI Units Library & Import [message #1823911 is a reply to message #755961] Fri, 03 April 2020 16:28 Go to previous message
jb tw is currently offline jb twFriend
Messages: 26
Registered: December 2019
Junior Member
Is this still the current workflow?
I can't find it in papyrus or i don't know where to look for it... What it find in the market place don't look useful to me
Over here https://www.eclipse.org/papyrus/components/marte/1.2.2/ it looks like latest update was from 2017
Previous Topic:Current Requirement & Upstream Requirement in UML Activity Diagram
Next Topic:"The chosen operation is not enabled"
Goto Forum:
  


Current Time: Sat Jan 16 04:05:40 GMT 2021

Powered by FUDForum. Page generated in 0.01701 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top