Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » JSDAI install problem
JSDAI install problem [message #754713] Fri, 04 November 2011 00:28 Go to next message
Andre Luiz is currently offline Andre LuizFriend
Messages: 7
Registered: August 2011
Junior Member
Hello,

I'm trying to install and use JSDAI (www.jsdai.net) under ubuntu 11.o4
with Eclipse Ganimede to no avail. The installation message I receive
when installing the plugin is,

Cannot complete the install because one or more required items could not
be found.
Software being installed: JSDAI Express-G Editor 4.3.0.v201010271301
(net.jsdai.express_g.feature.feature.group 4.3.0.v201010271301)
Missing requirement: JSDAI Common 4.1.6.v201010271301 (net.jsdai.common
4.1.6.v201010271301) requires 'bundle org.eclipse.ui [3.6.0,4.0.0)' but
it could not be found
Cannot satisfy dependency:
From: JSDAI ExpressDoc 4.1.6.v201010262121 (net.jsdai.express_doc
4.1.6.v201010262121)
To: bundle net.jsdai.common [4.1.0,5.0.0)
Cannot satisfy dependency:
From: JSDAI Express-G Editor 4.3.0.v201010271301
(net.jsdai.express_g.feature.feature.group 4.3.0.v201010271301)
To: net.jsdai.impexpWizards [4.1.3.v200806021255]
Cannot satisfy dependency:
From: JSDAI ExpressDoc Import/Export Wizard declarations
4.1.3.v200806021255 (net.jsdai.impexpWizards 4.1.3.v200806021255)
To: bundle net.jsdai.express_doc [4.1.0,5.0.0)

Would anyone know how to help me, please?

Thanks in advance,

Andre Luiz
Re: JSDAI install problem [message #754727 is a reply to message #754713] Fri, 04 November 2011 04:00 Go to previous messageGo to next message
David Wegener is currently offline David WegenerFriend
Messages: 1441
Registered: July 2009
Senior Member
On 11/03/2011 07:28 PM, Andre Luiz Tietbohl Ramos wrote:
> Hello,
>
> I'm trying to install and use JSDAI (www.jsdai.net) under ubuntu 11.o4
> with Eclipse Ganimede to no avail. The installation message I receive
> when installing the plugin is,
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: JSDAI Express-G Editor 4.3.0.v201010271301
> (net.jsdai.express_g.feature.feature.group 4.3.0.v201010271301)
> Missing requirement: JSDAI Common 4.1.6.v201010271301 (net.jsdai.common
> 4.1.6.v201010271301) requires 'bundle org.eclipse.ui [3.6.0,4.0.0)' but
> it could not be found
> Cannot satisfy dependency:
> From: JSDAI ExpressDoc 4.1.6.v201010262121 (net.jsdai.express_doc
> 4.1.6.v201010262121)
> To: bundle net.jsdai.common [4.1.0,5.0.0)
> Cannot satisfy dependency:
> From: JSDAI Express-G Editor 4.3.0.v201010271301
> (net.jsdai.express_g.feature.feature.group 4.3.0.v201010271301)
> To: net.jsdai.impexpWizards [4.1.3.v200806021255]
> Cannot satisfy dependency:
> From: JSDAI ExpressDoc Import/Export Wizard declarations
> 4.1.3.v200806021255 (net.jsdai.impexpWizards 4.1.3.v200806021255)
> To: bundle net.jsdai.express_doc [4.1.0,5.0.0)
>
> Would anyone know how to help me, please?
>
> Thanks in advance,
>
> Andre Luiz
Ganymede is version 3.4 based. It looks like the package you are trying
to install requires at least version 3.6. The current Eclipse version
is at 3.7.
Re: JSDAI install problem [message #756491 is a reply to message #754727] Mon, 14 November 2011 01:14 Go to previous messageGo to next message
Andre Luiz is currently offline Andre LuizFriend
Messages: 7
Registered: August 2011
Junior Member
Hello,

Thanks for the response. I installed Indigo Service Release 1 and
received the following error,

Cannot complete the install because one or more required items could not
be found.
Software currently installed: Shared profile 1.0.0.1316138634362
(SharedProfile_epp.package.java 1.0.0.1316138634362)
Missing requirement: Shared profile 1.0.0.1316138634362
(SharedProfile_epp.package.java 1.0.0.1316138634362) requires
'org.maven.ide.eclipse [1.0.100.20110804-1717]' but it could not be found

I have the following eclipse_indigo executable script,

#!/bin/sh

# work around for e#290395 / LP: #458703
# https://bugs.eclipse.org/bugs/show_bug.cgi?id=290395
# https://bugs.launchpad.net/bugs/458703
export GDK_NATIVE_WINDOWS=true

export MOZILLA_FIVE_HOME="/usr/lib/xulrunner-$(/usr/bin/xulrunner-1.9.2 --
gre-version)"

#ECLIPSE=/usr/lib/eclipse/eclipse
ECLIPSE=/usr/lib/eclipse_indigo/eclipse/eclipse

inject_update_site(){
if [ ! -e "$1" ] ; then
echo "W: Cannot find $1" 2>&1
return 1
fi
cat - >>"$1" <<EOF
repositories/http\:__download.eclipse.org_releases_galileo/enabled=true
repositories/http\:__download.eclipse.org_releases_galileo/isSystem=false
repositories/http\:__download.eclipse.org_releases_galileo/
nickname=Galileo Update Site
repositories/http\:__download.eclipse.org_releases_galileo/uri=http\://
download.eclipse.org/releases/galileo/
EOF

}


if [ ! -d ~/.eclipse/ ] ; then
$ECLIPSE -clean -initialize || exit $?
settings=`echo ~/.eclipse/org.eclipse.platform_*/p2/
org.eclipse.equinox.p2.engine/profileRegistry/
PlatformProfile.profile/.data/.settings/`
if [ ! -d "$settings" ] ; then
echo "W: Cannot inject update-sites, cannot find the correct
config." 2>&1
else
( inject_update_site "$settings/
org.eclipse.equinox.p2.metadata.repository.prefs" && \
inject_update_site "$settings/
org.eclipse.equinox.p2.artifact.repository.prefs" && \
echo "I: Injected update sites" ) || echo "W: Could not inject
update sites." 2>&1
fi
fi

exec $ECLIPSE "$@"

Any further help greatly appreciated,

Andre Luiz
Re: JSDAI install problem [message #756782 is a reply to message #756491] Tue, 15 November 2011 04:54 Go to previous messageGo to next message
David Wegener is currently offline David WegenerFriend
Messages: 1441
Registered: July 2009
Senior Member
On 11/13/2011 07:14 PM, Andre Luiz Tietbohl Ramos wrote:
> Hello,
>
> Thanks for the response. I installed Indigo Service Release 1 and
> received the following error,
>
> Cannot complete the install because one or more required items could not
> be found.
> Software currently installed: Shared profile 1.0.0.1316138634362
> (SharedProfile_epp.package.java 1.0.0.1316138634362)
> Missing requirement: Shared profile 1.0.0.1316138634362
> (SharedProfile_epp.package.java 1.0.0.1316138634362) requires
> 'org.maven.ide.eclipse [1.0.100.20110804-1717]' but it could not be found
>
> I have the following eclipse_indigo executable script,
>
> #!/bin/sh
>
> # work around for e#290395 / LP: #458703
> # https://bugs.eclipse.org/bugs/show_bug.cgi?id=290395
> # https://bugs.launchpad.net/bugs/458703
> export GDK_NATIVE_WINDOWS=true
>
> export MOZILLA_FIVE_HOME="/usr/lib/xulrunner-$(/usr/bin/xulrunner-1.9.2 --
> gre-version)"
>
> #ECLIPSE=/usr/lib/eclipse/eclipse
> ECLIPSE=/usr/lib/eclipse_indigo/eclipse/eclipse
>
> inject_update_site(){
> if [ ! -e "$1" ] ; then
> echo "W: Cannot find $1" 2>&1
> return 1
> fi
> cat ->>"$1"<<EOF
> repositories/http\:__download.eclipse.org_releases_galileo/enabled=true
> repositories/http\:__download.eclipse.org_releases_galileo/isSystem=false
> repositories/http\:__download.eclipse.org_releases_galileo/
> nickname=Galileo Update Site
> repositories/http\:__download.eclipse.org_releases_galileo/uri=http\://
> download.eclipse.org/releases/galileo/
> EOF
>
> }
>
>
> if [ ! -d ~/.eclipse/ ] ; then
> $ECLIPSE -clean -initialize || exit $?
> settings=`echo ~/.eclipse/org.eclipse.platform_*/p2/
> org.eclipse.equinox.p2.engine/profileRegistry/
> PlatformProfile.profile/.data/.settings/`
> if [ ! -d "$settings" ] ; then
> echo "W: Cannot inject update-sites, cannot find the correct
> config." 2>&1
> else
> ( inject_update_site "$settings/
> org.eclipse.equinox.p2.metadata.repository.prefs"&& \
> inject_update_site "$settings/
> org.eclipse.equinox.p2.artifact.repository.prefs"&& \
> echo "I: Injected update sites" ) || echo "W: Could not inject
> update sites." 2>&1
> fi
> fi
>
> exec $ECLIPSE "$@"
>
> Any further help greatly appreciated,
>
> Andre Luiz
>
The launch script indicates that you installed Eclipse from the Ubuntu
repositories. Don't do this. You will have problems installing
additional software.

Uninstall the Eclipse and download a package directly from the Eclipse
download page.
Re: JSDAI install problem [message #758136 is a reply to message #756782] Tue, 22 November 2011 03:18 Go to previous messageGo to next message
Andre Luiz is currently offline Andre LuizFriend
Messages: 7
Registered: August 2011
Junior Member
Hello,

I'm trying to install packages in Eclipse Indigo under Ubuntu 11.04 as
you suggested and receive this error message,

Cannot complete the install because one or more required items could not
be found.
Software currently installed: Shared profile 1.0.0.1316138634362
(SharedProfile_epp.package.java 1.0.0.1316138634362)
Missing requirement: Shared profile 1.0.0.1316138634362
(SharedProfile_epp.package.java 1.0.0.1316138634362) requires
'org.maven.ide.eclipse [1.0.100.20110804-1717]' but it could not be found

BTW, I removed all pre-installed eclipse because it was the Ganymede
version. Now, it is installed under /usr/lib/eclipse_indigo/eclipse as
shown below,

andreltr@stech:~$ cd /usr/lib/eclipse
andreltr@stech:/usr/lib/eclipse$ ls
plugins
andreltr@stech:/usr/lib/eclipse$ ls ../eclipse_indigo/
eclipse
andreltr@stech:/usr/lib/eclipse$ ls ../eclipse_indigo/eclipse/
about_files dropins eclipse.ini libcairo-swt.so readme
about.html eclipse epl-v10.html notice.html
artifacts.xml eclipse_indigo features p2
configuration eclipse_indigo~ icon.xpm plugins
andreltr@stech:/usr/lib/eclipse$

Nothing can be installed any longer. Would anyone be able to help me
please?

Thanks in advance,

Andre Luiz



On Mon, 14 Nov 2011 22:54:25 -0600, David Wegener wrote:

> On 11/13/2011 07:14 PM, Andre Luiz Tietbohl Ramos wrote:
>> Hello,
>>
>> Thanks for the response. I installed Indigo Service Release 1 and
>> received the following error,
>>
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software currently installed: Shared profile 1.0.0.1316138634362
>> (SharedProfile_epp.package.java 1.0.0.1316138634362)
>> Missing requirement: Shared profile 1.0.0.1316138634362
>> (SharedProfile_epp.package.java 1.0.0.1316138634362) requires
>> 'org.maven.ide.eclipse [1.0.100.20110804-1717]' but it could not be
>> found
>>
>> I have the following eclipse_indigo executable script,
>>
>> #!/bin/sh
>>
>> # work around for e#290395 / LP: #458703 #
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=290395 #
>> https://bugs.launchpad.net/bugs/458703 export GDK_NATIVE_WINDOWS=true
>>
>> export MOZILLA_FIVE_HOME="/usr/lib/xulrunner-$(/usr/bin/xulrunner-1.9.2
>> -- gre-version)"
>>
>> #ECLIPSE=/usr/lib/eclipse/eclipse
>> ECLIPSE=/usr/lib/eclipse_indigo/eclipse/eclipse
>>
>> inject_update_site(){
>> if [ ! -e "$1" ] ; then
>> echo "W: Cannot find $1" 2>&1
>> return 1
>> fi
>> cat ->>"$1"<<EOF
>> repositories/http\:__download.eclipse.org_releases_galileo/enabled=true
>> repositories/http\:__download.eclipse.org_releases_galileo/
isSystem=false
>> repositories/http\:__download.eclipse.org_releases_galileo/
>> nickname=Galileo Update Site
>> repositories/http\:__download.eclipse.org_releases_galileo/uri=http\://
>> download.eclipse.org/releases/galileo/ EOF
>>
>> }
>>
>>
>> if [ ! -d ~/.eclipse/ ] ; then
>> $ECLIPSE -clean -initialize || exit $? settings=`echo
>> ~/.eclipse/org.eclipse.platform_*/p2/
>> org.eclipse.equinox.p2.engine/profileRegistry/
>> PlatformProfile.profile/.data/.settings/`
>> if [ ! -d "$settings" ] ; then
>> echo "W: Cannot inject update-sites, cannot find the correct
>> config." 2>&1
>> else
>> ( inject_update_site "$settings/
>> org.eclipse.equinox.p2.metadata.repository.prefs"&& \
>> inject_update_site "$settings/
>> org.eclipse.equinox.p2.artifact.repository.prefs"&& \
>> echo "I: Injected update sites" ) || echo "W: Could not inject
>> update sites." 2>&1
>> fi
>> fi
>>
>> exec $ECLIPSE "$@"
>>
>> Any further help greatly appreciated,
>>
>> Andre Luiz
>>
> The launch script indicates that you installed Eclipse from the Ubuntu
> repositories. Don't do this. You will have problems installing
> additional software.
>
> Uninstall the Eclipse and download a package directly from the Eclipse
> download page.
Re: JSDAI install problem [message #758363 is a reply to message #758136] Tue, 22 November 2011 21:24 Go to previous message
David Wegener is currently offline David WegenerFriend
Messages: 1441
Registered: July 2009
Senior Member
On 11/21/2011 09:18 PM, Andre Luiz Tietbohl Ramos wrote:
> Hello,
>
> I'm trying to install packages in Eclipse Indigo under Ubuntu 11.04 as
> you suggested and receive this error message,
>
> Cannot complete the install because one or more required items could not
> be found.
> Software currently installed: Shared profile 1.0.0.1316138634362
> (SharedProfile_epp.package.java 1.0.0.1316138634362)
> Missing requirement: Shared profile 1.0.0.1316138634362
> (SharedProfile_epp.package.java 1.0.0.1316138634362) requires
> 'org.maven.ide.eclipse [1.0.100.20110804-1717]' but it could not be found
>

Eclipse seems to be looking for the Maven plugin. I'm not sure if it is
required by something you are trying to install or something already
installed.

You could try to install the Maven plugin from the Indigo update site.
The version referenced appears to be the current version on the update site.
> BTW, I removed all pre-installed eclipse because it was the Ganymede
> version. Now, it is installed under /usr/lib/eclipse_indigo/eclipse as
> shown below,
>
> andreltr@stech:~$ cd /usr/lib/eclipse
> andreltr@stech:/usr/lib/eclipse$ ls
> plugins
> andreltr@stech:/usr/lib/eclipse$ ls ../eclipse_indigo/
> eclipse
> andreltr@stech:/usr/lib/eclipse$ ls ../eclipse_indigo/eclipse/
> about_files dropins eclipse.ini libcairo-swt.so readme
> about.html eclipse epl-v10.html notice.html
> artifacts.xml eclipse_indigo features p2
> configuration eclipse_indigo~ icon.xpm plugins
> andreltr@stech:/usr/lib/eclipse$
>
> Nothing can be installed any longer. Would anyone be able to help me
> please?
>
> Thanks in advance,
>
> Andre Luiz
>
>
>
> On Mon, 14 Nov 2011 22:54:25 -0600, David Wegener wrote:
>
>> On 11/13/2011 07:14 PM, Andre Luiz Tietbohl Ramos wrote:
>>> Hello,
>>>
>>> Thanks for the response. I installed Indigo Service Release 1 and
>>> received the following error,
>>>
>>> Cannot complete the install because one or more required items could
>>> not be found.
>>> Software currently installed: Shared profile 1.0.0.1316138634362
>>> (SharedProfile_epp.package.java 1.0.0.1316138634362)
>>> Missing requirement: Shared profile 1.0.0.1316138634362
>>> (SharedProfile_epp.package.java 1.0.0.1316138634362) requires
>>> 'org.maven.ide.eclipse [1.0.100.20110804-1717]' but it could not be
>>> found
>>>
>>> I have the following eclipse_indigo executable script,
>>>
>>> #!/bin/sh
>>>
>>> # work around for e#290395 / LP: #458703 #
>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=290395 #
>>> https://bugs.launchpad.net/bugs/458703 export GDK_NATIVE_WINDOWS=true
>>>
>>> export MOZILLA_FIVE_HOME="/usr/lib/xulrunner-$(/usr/bin/xulrunner-1.9.2
>>> -- gre-version)"
>>>
>>> #ECLIPSE=/usr/lib/eclipse/eclipse
>>> ECLIPSE=/usr/lib/eclipse_indigo/eclipse/eclipse
>>>
>>> inject_update_site(){
>>> if [ ! -e "$1" ] ; then
>>> echo "W: Cannot find $1" 2>&1
>>> return 1
>>> fi
>>> cat ->>"$1"<<EOF
>>> repositories/http\:__download.eclipse.org_releases_galileo/enabled=true
>>> repositories/http\:__download.eclipse.org_releases_galileo/
> isSystem=false
>>> repositories/http\:__download.eclipse.org_releases_galileo/
>>> nickname=Galileo Update Site
>>> repositories/http\:__download.eclipse.org_releases_galileo/uri=http\://
>>> download.eclipse.org/releases/galileo/ EOF
>>>
>>> }
>>>
>>>
>>> if [ ! -d ~/.eclipse/ ] ; then
>>> $ECLIPSE -clean -initialize || exit $? settings=`echo
>>> ~/.eclipse/org.eclipse.platform_*/p2/
>>> org.eclipse.equinox.p2.engine/profileRegistry/
>>> PlatformProfile.profile/.data/.settings/`
>>> if [ ! -d "$settings" ] ; then
>>> echo "W: Cannot inject update-sites, cannot find the correct
>>> config." 2>&1
>>> else
>>> ( inject_update_site "$settings/
>>> org.eclipse.equinox.p2.metadata.repository.prefs"&& \
>>> inject_update_site "$settings/
>>> org.eclipse.equinox.p2.artifact.repository.prefs"&& \
>>> echo "I: Injected update sites" ) || echo "W: Could not inject
>>> update sites." 2>&1
>>> fi
>>> fi
>>>
>>> exec $ECLIPSE "$@"
>>>
>>> Any further help greatly appreciated,
>>>
>>> Andre Luiz
>>>
>> The launch script indicates that you installed Eclipse from the Ubuntu
>> repositories. Don't do this. You will have problems installing
>> additional software.
>>
>> Uninstall the Eclipse and download a package directly from the Eclipse
>> download page.
>
Previous Topic:Workspaces on smb:// URI ?
Next Topic:eclipse workbench help fails
Goto Forum:
  


Current Time: Tue Jun 22 02:47:50 GMT 2021

Powered by FUDForum. Page generated in 0.03385 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top