Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Plug-In not taking affect in Eclipse
Plug-In not taking affect in Eclipse [message #754543] Thu, 03 November 2011 07:50 Go to next message
Dev_Sharma987 is currently offline Dev_Sharma987Friend
Messages: 2
Registered: October 2011
Junior Member

I have created a plugin project in eclipse to create a new category and view. I run the MANIFEST.MF file as an eclipse application which opens a new eclipse window and I can see my plugin take affect. However, I want the plugin to be part of my standard eclipse installation.

For this I have exported the project to a jar, put the jar in the plugins folder and restarted eclipse. But I cannot see the changes take affect. I have also tried running eclipse from the command prompt with -clean option to force eclipse to search for new plugins. I have also tried putting the jar file in the dropins folder and restarting but nothing is working.

Any idea on what I might be missing ? I know the other option is to create feature but I wanted to understand what is wrong or missing in my approach.

Regards, Dev
Re: Plug-In not taking affect in Eclipse [message #754544 is a reply to message #754543] Thu, 03 November 2011 07:57 Go to previous message
Animesh Kumar is currently offline Animesh KumarFriend
Messages: 79
Registered: September 2010
Location: Bangalore
Member
Hi,
Maybe Eclipse is unable to register or load your jar directly from the plugins folder. It may be because you might not have included the plugin dependencies inside your jar.
Regards,
Animesh


Regards,
Animesh

[Updated on: Thu, 03 November 2011 08:04]

Report message to a moderator

Previous Topic:Basic XML editor w/o installing WTP?
Next Topic:PAR project runtime and deploy error
Goto Forum:
  


Current Time: Wed Jun 23 14:04:23 GMT 2021

Powered by FUDForum. Page generated in 0.02744 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top