Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » Problem with simple transformation
Problem with simple transformation [message #81398] Thu, 15 May 2008 17:27 Go to next message
Eclipse UserFriend
Originally posted by: jobamo.gmail.com

Hi!

I'm writing my first ATL's transformation for a project degree.
I have this problem: I'm trying to execute this transformation:

-- @atlcompiler atl2006
module ecore2maude; -- Module Template
create OUT : Maude from IN : Ecore;

rule clase2sort {
from
c : Ecore!EClass
to
s : Maude!Sort(
name <- c.name
)
}

and it produces an error:

GRAVE: ****** BEGIN Stack Trace
GRAVE: message: ERROR: could not find operation allInstancesFrom on
Ecore!EClass having supertypes: [Ecore!EClassifier, OclType, OclAny]
(including Java operations)
GRAVE: A.main() : ??#22 null
GRAVE: local variables = {self=ecore2maude : ASMModule}
GRAVE: local stack = []
GRAVE: A.__matcher__() : ??#1 null
GRAVE: local variables = {self=ecore2maude : ASMModule}
GRAVE: local stack = []
GRAVE: A.__matchclase2sort() : ??#4 null
GRAVE: local variables = {self=ecore2maude : ASMModule}
GRAVE: local stack = []
GRAVE: ****** END Stack Trace
INFO: Execution terminated due to error (see launch configuration to allow
continuation after errors).
GRAVE: ERROR: could not find operation allInstancesFrom on Ecore!EClass
having supertypes: [Ecore!EClassifier, OclType, OclAny] (including Java
operations)
java.lang.RuntimeException: ERROR: could not find operation
allInstancesFrom on Ecore!EClass having supertypes: [Ecore!EClassifier,
OclType, OclAny] (including Java operations)
at
org.eclipse.m2m.atl.engine.vm.SimpleDebugger.error(SimpleDeb ugger.java:185)
at
org.eclipse.m2m.atl.engine.vm.StackFrame.printStackTrace(Sta ckFrame.java:85)
at
org.eclipse.m2m.atl.engine.vm.StackFrame.printStackTrace(Sta ckFrame.java:81)
at
org.eclipse.m2m.atl.drivers.emf4atl.ASMEMFModelElement.invok e(ASMEMFModelElement.java:671)
at
org.eclipse.m2m.atl.engine.vm.ASMOperation.realExec(ASMOpera tion.java:230)
at org.eclipse.m2m.atl.engine.vm.ASMOperation.exec(ASMOperation .java:161)
at
org.eclipse.m2m.atl.engine.vm.nativelib.ASMOclAny.invoke(ASM OclAny.java:133)
at
org.eclipse.m2m.atl.engine.vm.nativelib.ASMOclAny.invoke(ASM OclAny.java:91)
at
org.eclipse.m2m.atl.engine.vm.ASMOperation.realExec(ASMOpera tion.java:230)
at org.eclipse.m2m.atl.engine.vm.ASMOperation.exec(ASMOperation .java:161)
at
org.eclipse.m2m.atl.engine.vm.nativelib.ASMOclAny.invoke(ASM OclAny.java:133)
at
org.eclipse.m2m.atl.engine.vm.nativelib.ASMOclAny.invoke(ASM OclAny.java:91)
at
org.eclipse.m2m.atl.engine.vm.ASMOperation.realExec(ASMOpera tion.java:230)
at org.eclipse.m2m.atl.engine.vm.ASMOperation.exec(ASMOperation .java:161)
at
org.eclipse.m2m.atl.engine.vm.ASMInterpreter.<init>(ASMInterpreter.java:289)
at org.eclipse.m2m.atl.engine.AtlLauncher.launch(AtlLauncher.ja va:155)
at org.eclipse.m2m.atl.engine.AtlLauncher.launch(AtlLauncher.ja va:105)
at org.eclipse.m2m.atl.engine.AtlLauncher.launch(AtlLauncher.ja va:81)
at
org.eclipse.m2m.atl.adt.launching.AtlRegularVM.runAtlLaunche r(AtlRegularVM.java:351)
at
org.eclipse.m2m.atl.adt.launching.AtlRegularVM.runAtlLaunche r(AtlRegularVM.java:453)
at
org.eclipse.m2m.atl.adt.launching.AtlRegularVM.launch(AtlReg ularVM.java:425)
at
org.eclipse.m2m.atl.adt.launching.AtlLaunchConfigurationDele gate.launch(AtlLaunchConfigurationDelegate.java:35)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:766)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:608)
at
org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:899)
at
org.eclipse.debug.internal.ui.DebugUIPlugin$7.run(DebugUIPlu gin.java:1102)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)



I'm trying to do:

-- @atlcompiler atl2006
module ecore2maude; -- Module Template
create OUT : Maude from IN : Ecore;

rule clase2sort {
from
c : Ecore!EClassifier(c.oclIsTypeOf(Ecore!EClass))
to
s : Maude!Sort(
name <- c.name
)
}

and it works!!


Where is the problem?
Anybody can help me??

Thanks!!
Re: [ATL] Problem with simple transformation [message #81543 is a reply to message #81398] Sat, 17 May 2008 10:23 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jobamo.gmail.com

Sorry, I didn't know that I have to write [ATL] in subject.
Excuse my poor english, too
Re: [ATL] Problem with simple transformation [message #81959 is a reply to message #81543] Wed, 21 May 2008 19:58 Go to previous messageGo to next message
neto Mising name is currently offline neto Mising nameFriend
Messages: 33
Registered: July 2009
Member
Guy,

your transformation looks like correct for me. maybe the problem is on
your ATL plugin (do you install all requirements?) or on your metamodel.
Re: [ATL] Problem with simple transformation [message #82066 is a reply to message #81959] Thu, 22 May 2008 16:45 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jobamo.gmail.com

Hi Netuh,

I have installed only an "ATL Ready-To-Use Bundle" (ATL Bundle 2.0
Standard Version). Do I need to install something else?
And I think that the metamodel works because it is tested with others
examples.

Thanks for try to help me
Re: [ATL] Problem with simple transformation [message #82166 is a reply to message #82066] Mon, 26 May 2008 10:03 Go to previous message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
Hello,

The version you use is out-of-date, you may have find it on the
"archive" page. This is a pre-version of the ATL 2.0 and was developped
when ATL was hosted in the GMT project.
The official 2.0.0 ATL version is not yet released and will be
synchronized with the Ganymede release. Here is a link to the download
page :
http://www.eclipse.org/modeling/m2m/downloads/index.php?proj ect=atl

Best regards,

William

J.Bautista a écrit :
> Hi Netuh,
>
> I have installed only an "ATL Ready-To-Use Bundle" (ATL Bundle 2.0
> Standard Version). Do I need to install something else?
> And I think that the metamodel works because it is tested with others
> examples.
>
> Thanks for try to help me
>
Previous Topic:[ATL] uml2 models transformation
Next Topic:[ATL] How to refer to superclasses
Goto Forum:
  


Current Time: Fri May 24 08:48:23 GMT 2019

Powered by FUDForum. Page generated in 0.01996 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top