Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » Get ATL for Eclipse 3.3.1.1?
Get ATL for Eclipse 3.3.1.1? [message #76991] Tue, 18 March 2008 19:48 Go to next message
John A. Murdie is currently offline John A. MurdieFriend
Messages: 13
Registered: July 2009
Junior Member
I've been asked to obtain ATL for Eclipse 3.3.1.1 on Slackware Linux 12.0
- I'm quite used to getting plugins using Eclipse Update Manager but I've
not found any obviously up-to-date instructions about how to do this for
ATL. I found http://download.eclipse.org/modeling/m2m/updates/site.xml and
created a new 'Remote site' called 'M2M Update Manager Site' with 'Help'
-> 'Software Updates' -> 'Find and Install' -> 'Search for new features'
but when I press 'Finish', all I get is a dialogue box containing the
unhelpful message:

No features found on the selected site(s). Choose a different site or site
category.

How do I get ATL for Eclipse 3.3.1.1 automatically? Is some documentation
missing?

Next I tried downloading and unzipping m2m-atl-SDK-I200803030819.zip from
http://www.eclipse.org/modeling/m2m/downloads/index.php?proj ect=atl ,
making sure that the plugins went in my Eclipse plugins directory, but I
can't be sure whether this has had the effect of installing ATL as I
require. When I subsequently do 'Help' -> 'Software Updates' -> 'Manage
Configuration', ATL is nowwhere to be seen in the list of installed
components at the top level; might it be hidden away somewhere underneath?
Re: Get ATL for Eclipse 3.3.1.1? [message #77244 is a reply to message #76991] Wed, 19 March 2008 17:58 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: quentin.glineur.obeo.fr

This is a multi-part message in MIME format.
--------------070404010605000407010809
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit

Hi,

This link is not effective. Try to use this one instead:
http://download.eclipse.org/modeling/m2m/updates/site-interi m.xml


John A. Murdie a
Re: Get ATL for Eclipse 3.3.1.1? [message #77308 is a reply to message #77244] Thu, 20 March 2008 09:49 Go to previous message
John A. Murdie is currently offline John A. MurdieFriend
Messages: 13
Registered: July 2009
Junior Member
Thank you, Quentin - that fixed the problem.

Bien à vous,

John A. Murdie
Previous Topic:[atl] thisModule.resolveTemp() for a called rule
Next Topic:[ATL] Model Inferencing
Goto Forum:
  


Current Time: Wed May 22 05:34:19 GMT 2019

Powered by FUDForum. Page generated in 0.01583 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top