Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Unable to run workflow in RCP
Unable to run workflow in RCP [message #713181] Mon, 08 August 2011 07:33 Go to next message
Arun  is currently offline Arun Friend
Messages: 26
Registered: July 2011
Junior Member
Hi,

I have created a RCP product for my DSL editor. The editor works fine, but when i run the generator, it shows a error dialog, which says,

"Problem runnig workflow :
Please put bundle org.eclipse.emf.mwe2.launch on your project classpath"

But that bundle is in dependencies list. What should i do to run the generator?

Thanks,
Arun
Re: Unable to run workflow in RCP [message #714611 is a reply to message #713181] Thu, 11 August 2011 05:08 Go to previous messageGo to next message
Arun  is currently offline Arun Friend
Messages: 26
Registered: July 2011
Junior Member
Any pointers or solutions ?
Re: Unable to run workflow in RCP [message #714623 is a reply to message #714611] Thu, 11 August 2011 06:18 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12229
Registered: July 2009
Senior Member
Hi,

If i understand your Problem you have a project in your rcp with a Workflow and now want to run the Workflow with a rightclick. Therefore the launch Plugin has to Be on the classpath of the project you want to Run the Workflow within. Just having the Plugin installed in the rcp is Not enhough.

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Unable to run workflow in RCP [message #714650 is a reply to message #714623] Thu, 11 August 2011 07:42 Go to previous messageGo to next message
Arun  is currently offline Arun Friend
Messages: 26
Registered: July 2011
Junior Member
Hi Christian,

I added the required jar in the classpath and that error has been resolved. But now while the generator it throws the following exception

0 ERROR Mwe2Launcher - [XtextLinkingDiagnostic: null:7 Couldn't resolve reference to Module 'workflow.AtgDslGenerator'.]

My Generator.mwe2 file (in RCP application) has following contents,


module Generator

var targetDir = "src-gen"
var modelPath = "src/model"

Workflow {
component = @workflow.AtgDslGenerator auto-inject {}
}


Am i missing something ?

Thanks,
Arun
Re: Unable to run workflow in RCP [message #714656 is a reply to message #714650] Thu, 11 August 2011 07:57 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12229
Registered: July 2009
Senior Member
Hi,

is this workflow.AtgDslGenerator on the path too?

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Unable to run workflow in RCP [message #714657 is a reply to message #714656] Thu, 11 August 2011 08:01 Go to previous messageGo to next message
Arun  is currently offline Arun Friend
Messages: 26
Registered: July 2011
Junior Member

I have exported the generator plugin alone and added in classpath. so workflow.AtgDslGenerator is in classpath. After adding that, got the following error,

0 ERROR Mwe2Launcher - Problems instantiating module Generator: Cannot resolve proxy: archive:file:/D:/plugins/com.atg.atgdsl.generator_1.0.0.jar!/workflow/AtgDslGenerator.mwe2#xtextLink_::0.3.4.0.1.4.1.1::0::/1
java.lang.RuntimeException: Problems instantiating module Generator: Cannot resolve proxy: archive:file:/D:/plugins/com.atg.atgdsl.generator_1.0.0.jar!/workflow/AtgDslGenerator.mwe2#xtextLink_::0.3.4.0.1.4.1.1::0::/1
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:73)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:74)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:35)
Caused by: java.lang.IllegalStateException: Cannot resolve proxy: archive:file:/D:/plugins/com.atg.atgdsl.generator_1.0.0.jar!/workflow/AtgDslGenerator.mwe2#xtextLink_::0.3.4.0.1.4.1.1::0::/1
at org.eclipse.xtext.common.types.util.JavaReflectAccess.getRawType(JavaReflectAccess.java:88)
at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.create(Mwe2ExecutionEngine.java:135)
at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.inCase(Mwe2ExecutionEngine.java:92)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Re: Unable to run workflow in RCP [message #1783388 is a reply to message #713181] Mon, 12 March 2018 14:43 Go to previous message
tom darboux is currently offline tom darbouxFriend
Messages: 2
Registered: March 2018
Junior Member
I had the same problem on linux on I solve it by installing the Plug-in Developers Environment (PDE).


Help → Install New Software... → Choose The Eclipse Project Updates in field Work With → Filter for RCP Plug-In
Previous Topic:Unable to launch mwe2 workflow
Next Topic:Working with multiple installed versions of your language plugin
Goto Forum:
  


Current Time: Thu Sep 20 03:11:24 GMT 2018

Powered by FUDForum. Page generated in 0.02136 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top