Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Xtext 2.0 plugin (Which versions of eclipse are compatiable with my Xtext 2.0 plugin? )
Xtext 2.0 plugin [message #711756] Sat, 06 August 2011 15:47 Go to next message
Caner Friend
Messages: 98
Registered: July 2011
Member
Hello
I have implemented a Xtext 2.0 plugin which has been installed and runs fine on Indigo. However I couldnt install on helios 3.6.2 because of dependencies errorr for Xtext 2.0 .

I want to ask that is it a normal result and Which versions of eclipse are compatiable with my Xtext 2.0 plugin?

BR
Caner

[Updated on: Sat, 06 August 2011 16:09]

Report message to a moderator

Re: Xtext 2.0 plugin [message #711757 is a reply to message #711756] Sat, 06 August 2011 15:55 Go to previous messageGo to next message
Caner Friend
Messages: 98
Registered: July 2011
Member
PS: Additionally, I have implemented my plugin with Helios 3.6.2 ( and to notice again with Xtext 2.0)
Caner
Re: Xtext 2.0 plugin [message #711798 is a reply to message #711757] Sat, 06 August 2011 17:03 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 13888
Registered: July 2009
Senior Member
hi,

http://www.eclipse.org/forums/index.php/m/669557/?srch=xtext+2.0+eclipse+helios#msg_669557

can you be a bit more expressive on the errors you get? if you have already an eclipse 3.6. with xtext 2.0 installed you must somehow got Xtext 2.0 installed there Wink

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Xtext 2.0 plugin [message #711813 is a reply to message #711798] Sat, 06 August 2011 17:24 Go to previous messageGo to next message
Caner Friend
Messages: 98
Registered: July 2011
Member
Hi Christian

I have already implemented a wizard on propose, how can i manipulate DSLProposalProvider, when the Xtext plugin is installed?

BR
Caner
Re: Xtext 2.0 plugin [message #711814 is a reply to message #711813] Sat, 06 August 2011 17:26 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 13888
Registered: July 2009
Senior Member
Hi,

i do not understad this question.

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Xtext 2.0 plugin [message #711865 is a reply to message #711814] Sat, 06 August 2011 19:01 Go to previous messageGo to next message
Caner Friend
Messages: 98
Registered: July 2011
Member
Sorry i mixed the subject please look here
http://www.eclipse.org/forums/index.php/t/232405/


Regarding to this subject;

I tried to install my plugin on a helios which has not xtext sdk. Can i not install if the sdk is not install on a helios 3.6..

Caner

[Updated on: Sat, 06 August 2011 19:07]

Report message to a moderator

Re: Xtext 2.0 plugin [message #711879 is a reply to message #711865] Sat, 06 August 2011 19:17 Go to previous message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 13888
Registered: July 2009
Senior Member
Hi,

you have to add an update site pointing to xtext 2.0 and it's transitive dependencies of course to your eclipse 3.6 you want to install the plugin to.
this is a std eclipse / p2 problem and nothing xtext specific.

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:Wizard for mydsl
Next Topic:Preprocessor and Macros
Goto Forum:
  


Current Time: Thu Apr 22 18:40:03 GMT 2021

Powered by FUDForum. Page generated in 0.01894 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top