Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » EMF Client » How to register model in ECP current? (0.8x)
How to register model in ECP current? (0.8x) [message #708197] Tue, 02 August 2011 15:02 Go to next message
Nikolay Kasyanov is currently offline Nikolay KasyanovFriend
Messages: 30
Registered: September 2010
Location: Russia
Member
Hi,
is anyone there? Smile

How can I register a model for ECP in current builds? Looks like extension point org.eclipse.emf.ecp.model.ecppackage is broken because it's schema file doesn't exists.

ECP installed from http://download.eclipse.org/emf-store/ update site.
Re: How to register model in ECP current? (0.8x) [message #713684 is a reply to message #708197] Mon, 08 August 2011 19:34 Go to previous messageGo to next message
Mike Haney is currently offline Mike HaneyFriend
Messages: 25
Registered: June 2011
Junior Member
We ran into the same thing with the broken schema, however it works perfectly fine if you edit plugin.xml manually, as such:

   <extension point="org.eclipse.emf.ecp.model.ecppackage">
	  <modelPackage modelPackage="http://mymodeluri/1.0" />
	  <modelPackage modelPackage="http://anothermodeluri/1.0" />

          ... repeat for as many models as you need to register

   </extension>
Re: How to register model in ECP current? (0.8x) [message #713695 is a reply to message #708197] Mon, 08 August 2011 20:08 Go to previous message
Nikolay Kasyanov is currently offline Nikolay KasyanovFriend
Messages: 30
Registered: September 2010
Location: Russia
Member
It works, thanks!
Previous Topic:Welcome to eclipse.emfclient
Next Topic:Want to contribute to ECP - a few questions
Goto Forum:
  


Current Time: Wed Sep 19 23:21:13 GMT 2018

Powered by FUDForum. Page generated in 0.01590 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top