Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » PDT 1.0.3 and Eclipse 3.4 (Ganymede)
PDT 1.0.3 and Eclipse 3.4 (Ganymede) [message #73539] Mon, 16 June 2008 22:19 Go to next message
Shawn Clark is currently offline Shawn ClarkFriend
Messages: 70
Registered: July 2009
Member
Trying to get PDT 1.0.3 installed with the latest release of 3.4.

1. Downloaded eclipse-SDK-3.4RC4-win32.zip
2. Extracted and setup Eclipse
3. Downloaded org.eclipse.php_feature-R20080603.zip
4. Extraced 1.0.3 and noticed in the feature.xml under the features
folder that the required components are:

<requires>
<import feature="org.eclipse.wst" version="2.0.0"
match="compatible"/>
<import feature="org.eclipse.platform" version="3.3.0"
match="compatible"/>
</requires>

5. The platform is already installed but is 3.4.0 (3.4.0.v20080606)
6. Installed the Web Standard Tools for 3.4 (3.0.0.v200806040035)

At this point I tried to get the PDT running in Eclipse 3.4 but it won't
enable itself for use. My main concerns are that the WST is now 3.0.0
and the platform is 3.4.0. Will that work okay with PDT?

I also checked the release web page about it needing EMF SDO XSD 2.3.2,
GEF 3.3.2 and WTP 2.0.2 so I installed the complementing versions for
the Ganymede release:

EMF Runtime - 2.4.0.v200806091234
XSD Runtime - 2.4.0.v200806091234
EMF SDO Runtime - 2.4.0.v200806091234
GEF - 3.4.0.v20080115
Web Developer Tools - 3.0.0v200806040035 (I believe this is the
replacement for WTP)

Even after installing those add-ons I still can't get the PDT to run.

Any suggestions???

--
Shawn Clark
Re: PDT 1.0.3 and Eclipse 3.4 (Ganymede) [message #73556 is a reply to message #73539] Mon, 16 June 2008 22:29 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: codeslave.ca.ibm.com

AFAIK, PDT 1.0.x won't run on Eclipse 3.4. You want PDT 1.1.

http://wiki.eclipse.org/PDT/Installation#Eclipse_3.4_.2F_Gan ymede_.2F_PDT_1.1

Nick

Shawn Clark wrote:
> Trying to get PDT 1.0.3 installed with the latest release of 3.4.
>
> 1. Downloaded eclipse-SDK-3.4RC4-win32.zip
> 2. Extracted and setup Eclipse
> 3. Downloaded org.eclipse.php_feature-R20080603.zip
> 4. Extraced 1.0.3 and noticed in the feature.xml under the features
> folder that the required components are:
>
> <requires>
> <import feature="org.eclipse.wst" version="2.0.0"
> match="compatible"/>
> <import feature="org.eclipse.platform" version="3.3.0"
> match="compatible"/>
> </requires>
>
> 5. The platform is already installed but is 3.4.0 (3.4.0.v20080606)
> 6. Installed the Web Standard Tools for 3.4 (3.0.0.v200806040035)
>
> At this point I tried to get the PDT running in Eclipse 3.4 but it won't
> enable itself for use. My main concerns are that the WST is now 3.0.0
> and the platform is 3.4.0. Will that work okay with PDT?
>
> I also checked the release web page about it needing EMF SDO XSD 2.3.2,
> GEF 3.3.2 and WTP 2.0.2 so I installed the complementing versions for
> the Ganymede release:
>
> EMF Runtime - 2.4.0.v200806091234
> XSD Runtime - 2.4.0.v200806091234
> EMF SDO Runtime - 2.4.0.v200806091234
> GEF - 3.4.0.v20080115
> Web Developer Tools - 3.0.0v200806040035 (I believe this is the
> replacement for WTP)
>
> Even after installing those add-ons I still can't get the PDT to run.
>
> Any suggestions???
>
> --
> Shawn Clark

--
Nick Boldt :: Release Engineer, IBM Toronto Lab
Eclipse Modeling :: http://www.eclipse.org/modeling
http://wiki.eclipse.org/index.php/User:Nickb
Re: PDT 1.0.3 and Eclipse 3.4 (Ganymede) [message #73574 is a reply to message #73556] Mon, 16 June 2008 22:34 Go to previous messageGo to next message
Shawn Clark is currently offline Shawn ClarkFriend
Messages: 70
Registered: July 2009
Member
Thanks for the link. From my understanding a release of 1.1 isn't going
to be available until the middle of September while Eclipse 3.4 is
available shortly. Is the 1.1 far enough along to be in a usable state
for development work?

--
Shawn Clark

Nick Boldt wrote:
> AFAIK, PDT 1.0.x won't run on Eclipse 3.4. You want PDT 1.1.
>
> http://wiki.eclipse.org/PDT/Installation#Eclipse_3.4_.2F_Gan ymede_.2F_PDT_1.1
>
>
> Nick
>
> Shawn Clark wrote:
>> Trying to get PDT 1.0.3 installed with the latest release of 3.4.
>>
>> 1. Downloaded eclipse-SDK-3.4RC4-win32.zip
>> 2. Extracted and setup Eclipse
>> 3. Downloaded org.eclipse.php_feature-R20080603.zip
>> 4. Extraced 1.0.3 and noticed in the feature.xml under the features
>> folder that the required components are:
>>
>> <requires>
>> <import feature="org.eclipse.wst" version="2.0.0"
>> match="compatible"/>
>> <import feature="org.eclipse.platform" version="3.3.0"
>> match="compatible"/>
>> </requires>
>>
>> 5. The platform is already installed but is 3.4.0 (3.4.0.v20080606)
>> 6. Installed the Web Standard Tools for 3.4 (3.0.0.v200806040035)
>>
>> At this point I tried to get the PDT running in Eclipse 3.4 but it
>> won't enable itself for use. My main concerns are that the WST is now
>> 3.0.0 and the platform is 3.4.0. Will that work okay with PDT?
>>
>> I also checked the release web page about it needing EMF SDO XSD
>> 2.3.2, GEF 3.3.2 and WTP 2.0.2 so I installed the complementing
>> versions for the Ganymede release:
>>
>> EMF Runtime - 2.4.0.v200806091234
>> XSD Runtime - 2.4.0.v200806091234
>> EMF SDO Runtime - 2.4.0.v200806091234
>> GEF - 3.4.0.v20080115
>> Web Developer Tools - 3.0.0v200806040035 (I believe this is the
>> replacement for WTP)
>>
>> Even after installing those add-ons I still can't get the PDT to run.
>>
>> Any suggestions???
>>
>> --
>> Shawn Clark
>
Re: PDT 1.0.3 and Eclipse 3.4 (Ganymede) [message #73591 is a reply to message #73574] Tue, 17 June 2008 02:11 Go to previous message
Eclipse UserFriend
Originally posted by: codeslave.ca.ibm.com

Try it and see. 1.1 is due in September, along with Eclipse 3.4.1.

Here's hoping that the PDT guys decide next year to align with Io
(Eclipse 3.5's coordinated release). *Hint, hint!*

Nick

Shawn Clark wrote:
> Thanks for the link. From my understanding a release of 1.1 isn't going
> to be available until the middle of September while Eclipse 3.4 is
> available shortly. Is the 1.1 far enough along to be in a usable state
> for development work?
>
> --
> Shawn Clark
>
> Nick Boldt wrote:
>> AFAIK, PDT 1.0.x won't run on Eclipse 3.4. You want PDT 1.1.
>>
>> http://wiki.eclipse.org/PDT/Installation#Eclipse_3.4_.2F_Gan ymede_.2F_PDT_1.1
>>
>>
>> Nick
>>
>> Shawn Clark wrote:
>>> Trying to get PDT 1.0.3 installed with the latest release of 3.4.
>>>
>>> 1. Downloaded eclipse-SDK-3.4RC4-win32.zip
>>> 2. Extracted and setup Eclipse
>>> 3. Downloaded org.eclipse.php_feature-R20080603.zip
>>> 4. Extraced 1.0.3 and noticed in the feature.xml under the features
>>> folder that the required components are:
>>>
>>> <requires>
>>> <import feature="org.eclipse.wst" version="2.0.0"
>>> match="compatible"/>
>>> <import feature="org.eclipse.platform" version="3.3.0"
>>> match="compatible"/>
>>> </requires>
>>>
>>> 5. The platform is already installed but is 3.4.0 (3.4.0.v20080606)
>>> 6. Installed the Web Standard Tools for 3.4 (3.0.0.v200806040035)
>>>
>>> At this point I tried to get the PDT running in Eclipse 3.4 but it
>>> won't enable itself for use. My main concerns are that the WST is now
>>> 3.0.0 and the platform is 3.4.0. Will that work okay with PDT?
>>>
>>> I also checked the release web page about it needing EMF SDO XSD
>>> 2.3.2, GEF 3.3.2 and WTP 2.0.2 so I installed the complementing
>>> versions for the Ganymede release:
>>>
>>> EMF Runtime - 2.4.0.v200806091234
>>> XSD Runtime - 2.4.0.v200806091234
>>> EMF SDO Runtime - 2.4.0.v200806091234
>>> GEF - 3.4.0.v20080115
>>> Web Developer Tools - 3.0.0v200806040035 (I believe this is the
>>> replacement for WTP)
>>>
>>> Even after installing those add-ons I still can't get the PDT to run.
>>>
>>> Any suggestions???
>>>
>>> --
>>> Shawn Clark
>>

--
Nick Boldt :: Release Engineer, IBM Toronto Lab
Eclipse Modeling :: http://www.eclipse.org/modeling
http://wiki.eclipse.org/index.php/User:Nickb
Previous Topic:Where is keyword/syntax highlighting implemented?
Next Topic:Problems after upgrade
Goto Forum:
  


Current Time: Tue Jan 31 14:47:05 GMT 2023

Powered by FUDForum. Page generated in 0.20065 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top