Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Xtext from 2 ecore files
Xtext from 2 ecore files [message #697739] Sun, 17 July 2011 22:31 Go to next message
Bruno Coudoin is currently offline Bruno CoudoinFriend
Messages: 2
Registered: July 2011
Junior Member
Hi,

Using Eclipse Indigo, I Have a model that includes a sub model. I generate a DSL using XText 2.0.0. When I run the editor, it ends up with the error:
An internal error occurred during: "XtextReconcilerJob".
java.lang.IllegalStateException: Unresolved proxy h ttp://test.com/TestModel#//Program. Make sure the EPackage has been registered.

I have seen a couple of old post relating the very same issue but could not determine what is the solution.

Any idea ?
Re: Xtext from 2 ecore files [message #697765 is a reply to message #697739] Mon, 18 July 2011 01:04 Go to previous messageGo to next message
Mirko Raner is currently offline Mirko RanerFriend
Messages: 98
Registered: July 2009
Location: New York City, NY
Member
I take it you checked that your plugin.xml contains a org.eclipse.emf.ecore.generated_package extension that registers the EPackage for the sub-model?

HTH,

Mirko
Re: Xtext from 2 ecore files [message #697880 is a reply to message #697765] Mon, 18 July 2011 09:21 Go to previous message
Bruno Coudoin is currently offline Bruno CoudoinFriend
Messages: 2
Registered: July 2011
Junior Member
While trying your advice, I found out that the URI by which my model is searched at run time by my editor was not the same as the one in my model itself. Fixing the model plugin.xml fixed the issue.

Thanks,

Bruno.
Previous Topic:How to transform xText to XMI
Next Topic:Beginner : need xtend help
Goto Forum:
  


Current Time: Wed Sep 23 06:52:37 GMT 2020

Powered by FUDForum. Page generated in 0.02505 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top