Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » For those using Teneo from cvs: HEAD is Teneo for EMF 2.3 , Branch: R0_7_maintenance is EMF 2.2
For those using Teneo from cvs: HEAD is Teneo for EMF 2.3 , Branch: R0_7_maintenance is EMF 2.2 [message #70737] Wed, 07 February 2007 17:12 Go to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi,
For those using Teneo from cvs. I am working on upgrading Teneo to EMF 2.3/jdk 1.5. The related
changes are being made in cvs HEAD.
The EMF 2.2 release of Teneo is from now maintained in the R0_7_maintenance branch.

To switch your current version to the maintenance branch right click on each project and select:
Replace With > Another Branch or Version
Click Refresh Tags and the R0_7_maintenance branch should show up, select it and click ok.

I will be doing builds for both EMF 2.2 and EMF 2.3. The EMF 2.2 builds with be called maintenance
builds (build id starts with M), the EMF 2.3 builds will be so-called integration build (build id
starts with I).

--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: For those using Teneo from cvs: HEAD is Teneo for EMF 2.3 , Branch: R0_7_maintenance is EMF 2.2 [message #70873 is a reply to message #70737] Thu, 08 February 2007 04:37 Go to previous messageGo to next message
Brian Vetter is currently offline Brian VetterFriend
Messages: 74
Registered: July 2009
Member
So does moving to EMF 2.3 really mean having to upgrade to Eclipse 3.3
as it states in the EMF 2.3 upgrade plan or does it still work in an
Eclipse 3.2.1 environment?

Brian

Martin Taal wrote:
> Hi,
> For those using Teneo from cvs. I am working on upgrading Teneo to EMF
> 2.3/jdk 1.5. The related changes are being made in cvs HEAD.
> The EMF 2.2 release of Teneo is from now maintained in the
> R0_7_maintenance branch.
>
> To switch your current version to the maintenance branch right click on
> each project and select: Replace With > Another Branch or Version
> Click Refresh Tags and the R0_7_maintenance branch should show up,
> select it and click ok.
>
> I will be doing builds for both EMF 2.2 and EMF 2.3. The EMF 2.2 builds
> with be called maintenance builds (build id starts with M), the EMF 2.3
> builds will be so-called integration build (build id starts with I).
>
Re: For those using Teneo from cvs: HEAD is Teneo for EMF 2.3 , Branch: R0_7_maintenance is EMF 2.2 [message #70974 is a reply to message #70873] Thu, 08 February 2007 12:07 Go to previous message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

Brian,

The platform did deprecate APIs in 3.3 and provided new replacements
which we have started using so I don't think EMF 2.3 will function well
in Eclipse 3.2.x.


Brian Vetter wrote:
> So does moving to EMF 2.3 really mean having to upgrade to Eclipse 3.3
> as it states in the EMF 2.3 upgrade plan or does it still work in an
> Eclipse 3.2.1 environment?
>
> Brian
>
> Martin Taal wrote:
>> Hi,
>> For those using Teneo from cvs. I am working on upgrading Teneo to
>> EMF 2.3/jdk 1.5. The related changes are being made in cvs HEAD.
>> The EMF 2.2 release of Teneo is from now maintained in the
>> R0_7_maintenance branch.
>>
>> To switch your current version to the maintenance branch right click
>> on each project and select: Replace With > Another Branch or Version
>> Click Refresh Tags and the R0_7_maintenance branch should show up,
>> select it and click ok.
>>
>> I will be doing builds for both EMF 2.2 and EMF 2.3. The EMF 2.2
>> builds with be called maintenance builds (build id starts with M),
>> the EMF 2.3 builds will be so-called integration build (build id
>> starts with I).
>>
Re: For those using Teneo from cvs: HEAD is Teneo for EMF 2.3 , Branch: R0_7_maintenance is EMF 2.2 [message #602329 is a reply to message #70737] Thu, 08 February 2007 04:37 Go to previous message
Brian Vetter is currently offline Brian VetterFriend
Messages: 74
Registered: July 2009
Member
So does moving to EMF 2.3 really mean having to upgrade to Eclipse 3.3
as it states in the EMF 2.3 upgrade plan or does it still work in an
Eclipse 3.2.1 environment?

Brian

Martin Taal wrote:
> Hi,
> For those using Teneo from cvs. I am working on upgrading Teneo to EMF
> 2.3/jdk 1.5. The related changes are being made in cvs HEAD.
> The EMF 2.2 release of Teneo is from now maintained in the
> R0_7_maintenance branch.
>
> To switch your current version to the maintenance branch right click on
> each project and select: Replace With > Another Branch or Version
> Click Refresh Tags and the R0_7_maintenance branch should show up,
> select it and click ok.
>
> I will be doing builds for both EMF 2.2 and EMF 2.3. The EMF 2.2 builds
> with be called maintenance builds (build id starts with M), the EMF 2.3
> builds will be so-called integration build (build id starts with I).
>
Re: For those using Teneo from cvs: HEAD is Teneo for EMF 2.3 , Branch: R0_7_maintenance is EMF 2.2 [message #602351 is a reply to message #70873] Thu, 08 February 2007 12:07 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31543
Registered: July 2009
Senior Member
Brian,

The platform did deprecate APIs in 3.3 and provided new replacements
which we have started using so I don't think EMF 2.3 will function well
in Eclipse 3.2.x.


Brian Vetter wrote:
> So does moving to EMF 2.3 really mean having to upgrade to Eclipse 3.3
> as it states in the EMF 2.3 upgrade plan or does it still work in an
> Eclipse 3.2.1 environment?
>
> Brian
>
> Martin Taal wrote:
>> Hi,
>> For those using Teneo from cvs. I am working on upgrading Teneo to
>> EMF 2.3/jdk 1.5. The related changes are being made in cvs HEAD.
>> The EMF 2.2 release of Teneo is from now maintained in the
>> R0_7_maintenance branch.
>>
>> To switch your current version to the maintenance branch right click
>> on each project and select: Replace With > Another Branch or Version
>> Click Refresh Tags and the R0_7_maintenance branch should show up,
>> select it and click ok.
>>
>> I will be doing builds for both EMF 2.2 and EMF 2.3. The EMF 2.2
>> builds with be called maintenance builds (build id starts with M),
>> the EMF 2.3 builds will be so-called integration build (build id
>> starts with I).
>>


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:[Teneo] Setting a "unique-key" attribute on a many-to-one association using Eannotations w
Next Topic:Converting .ecore to .genmodel (EMF/GMF)
Goto Forum:
  


Current Time: Fri Oct 23 12:23:29 GMT 2020

Powered by FUDForum. Page generated in 0.01694 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top