Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Synchronization between model editor and diagram editor
icon5.gif  Synchronization between model editor and diagram editor [message #696108] Wed, 13 July 2011 09:36
Missing name Missing name is currently offline Missing name Missing nameFriend
Messages: 7
Registered: March 2011
Junior Member
Hello,

I created a model and diagram editor for my ecore model. But I noticed a strange behavior:

1. I created a "WorldGraph Diagram" and saved the My.worldgraph and My.worldgraph_diagram.
2. I added some elements to the diagram, saved and closed the document.
3. After that the Model Editor showed the new added elements ... n1 Smile
4. Then I opened the diagram again and added some new elements ... save and close.

But in this case the model editor does not show the updated elements! So the model file was not changed after the second modification in the diagram!

Does anybody know what's wrong here? (I don't get any exception or error)
It seem that the model and diagram is not synchronized! Sad

Best regards
Stefan
Previous Topic:Bug in hide selection / ShapeNodeEditPart: Not restoring edges/links properly on undo
Next Topic:GMF Tooling in Indigo
Goto Forum:
  


Current Time: Mon Mar 08 13:34:19 GMT 2021

Powered by FUDForum. Page generated in 0.01395 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top