Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Manifest error in project generator wizard
Manifest error in project generator wizard [message #695454] Mon, 11 July 2011 19:26 Go to next message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
Hi there. I followed the steps to build out a project generator wizard for my dsl that I have defined. It works perfectly and I can create an instance of my dsl (in a new project) and the call to my generator gets delegated correctly. However, whenever I create a new project for my dsl using the plugin, I get this error in my manifest file

Bundle 'org.eclipse.xtend.util.stdlib' cannot be resolved.
Here is my MANIFEST.MF file. The offending line of code is:

"org.eclipse.xtend.util.stdlib"

Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: SoapServiceDSL
Bundle-Vendor: My Company
Bundle-Version: 1.0.0
Bundle-SymbolicName: SoapServiceDSL; singleton:=true
Bundle-ActivationPolicy: lazy
Require-Bundle: com.ibm.icu,
 org.eclipse.xtext,
 org.eclipse.xtext.generator,
 org.eclipse.xtend,
 org.eclipse.xtend.typesystem.emf,
 org.eclipse.xpand,
 de.itemis.xtext.antlr;resolution:=optional,
 org.eclipse.xtend.util.stdlib,
 org.eclipse.emf.mwe2.launch;resolution:=optional,
 org.xtext.slicing.generator
Import-Package: org.apache.log4j,
 org.apache.commons.logging
Bundle-RequiredExecutionEnvironment: J2SE-1.5


I am using XText version 1.0.2, with eclipse version 3.6.1 and java 1.6_20
Any ideas what this error appears? It cause me any problems, but it means that my project will always have an error symbol in eclipse. Thanks

[Updated on: Mon, 11 July 2011 19:26]

Report message to a moderator

Re: Manifest error in project generator wizard [message #695467 is a reply to message #695454] Mon, 11 July 2011 20:31 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13613
Registered: July 2009
Senior Member
Hi,

did you check that the plugin org.eclipse.xtend.util.stdlib is part of your target platform / product / runtime app you deploy your dsl too? (e.g. check plug-in view in your runtime eclipse)

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Manifest error in project generator wizard [message #695468 is a reply to message #695467] Mon, 11 July 2011 20:39 Go to previous messageGo to next message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
You're right, it's not there. I'm going to install it via eclipse from the repository "http://download.eclipse.org/modeling/tmf/updates/releases". All I can find in there under XTend is "Xtend2 SDK", is this what I need? Thanks very much for the help on this.
Re: Manifest error in project generator wizard [message #695475 is a reply to message #695468] Mon, 11 July 2011 20:56 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13613
Registered: July 2009
Senior Member
Hi,

the plugin org.eclipse.xtend.util.stdlib was and still is part of Xpand/Xtend(1) and not Xtend(2). Xtend2 is part of Xtext 2.0.0

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Manifest error in project generator wizard [message #695477 is a reply to message #695475] Mon, 11 July 2011 21:00 Go to previous messageGo to next message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
Hhhmm, I don't have that installed. I have Xtext UI and SDK version 1.0.2. I use the following url to try and install Xtext/Xpand v1 (http://download.eclipse.org/modeling/tmf/updates/releases) but all that I can find are version 2. Am I looking at the right url? If not, do you know how I can get it? I tried google, but no luck. Thanks

[Updated on: Mon, 11 July 2011 21:01]

Report message to a moderator

Re: Manifest error in project generator wizard [message #695478 is a reply to message #695477] Mon, 11 July 2011 21:04 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13613
Registered: July 2009
Senior Member
No, Xpand is part of m2t. just have a look at the std. Helios Update site. ~Christian

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Manifest error in project generator wizard [message #695479 is a reply to message #695478] Mon, 11 July 2011 21:05 Go to previous messageGo to next message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
Hi Christian, what do you mean when you refer to 'm2t' and 'std'? Thanks JD
Re: Manifest error in project generator wizard [message #695480 is a reply to message #695479] Mon, 11 July 2011 21:07 Go to previous messageGo to next message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
I see now, I just installed via the Helios update site. I'm installing xtend version 1.0.1v2, that's all that seems to be available to me. I hope that works for xtext version 1.0.2. Thanks again for the help
Re: Manifest error in project generator wizard [message #695484 is a reply to message #695480] Mon, 11 July 2011 21:11 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13613
Registered: July 2009
Senior Member
Hi, yes 1.0.x should be fine ~Christian

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Manifest error in project generator wizard [message #695488 is a reply to message #695484] Mon, 11 July 2011 21:28 Go to previous messageGo to next message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
Still no joy. The error is still there after installing xtend v1.0.1

I opened the eclipse view with the installed plugins and I can see:

org.eclipse.xtend
org.eclipse.xtend.check.ui
org.eclipse.xtend.profiler
org.eclipse.xtend.shared.ui
org.eclipse.xtend.typesystem.emf
org.eclipse.xtend.typesystem.emf.ui
org.eclipse.xtend.ui


but I can't see

org.eclipse.xtend.util.stdlib


Have I maybe forgotten something else?

Thanks

[Updated on: Mon, 11 July 2011 21:28]

Report message to a moderator

Re: Manifest error in project generator wizard [message #695492 is a reply to message #695488] Mon, 11 July 2011 21:43 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13613
Registered: July 2009
Senior Member
Hi, are we now talking about your dev time eclipse or the runtime eclipse? Regards Christian

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Manifest error in project generator wizard [message #695494 is a reply to message #695492] Mon, 11 July 2011 21:49 Go to previous messageGo to next message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
Both. I don't see it installed in either environments. How I'm checking is by clicking on Window -> Show view -> Plug-ins
Regards
JD

[Updated on: Mon, 11 July 2011 21:51]

Report message to a moderator

Re: Manifest error in project generator wizard [message #695496 is a reply to message #695494] Mon, 11 July 2011 21:52 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13613
Registered: July 2009
Senior Member
Hi, very strange. If you have a look at the plugins dir it's not contained there neither?

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de

[Updated on: Mon, 11 July 2011 21:54]

Report message to a moderator

Re: Manifest error in project generator wizard [message #695499 is a reply to message #695496] Mon, 11 July 2011 21:55 Go to previous messageGo to next message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
Nope. I just checked the 'plugins' directory under my eclipse home folder and I can't see anything relating to 'org.eclipse.xtend.util.stdlib'. I'm installing xpand now to see if that will help. I also googled 'org.eclipse.xtend.util.stdlib' and can't find any information relating to where I can get a hold of it. Regards JD
Re: Manifest error in project generator wizard [message #695500 is a reply to message #695496] Mon, 11 July 2011 21:57 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13613
Registered: July 2009
Senior Member
Btw i have

org.eclipse.xtend
org.eclipse.xtend.check.ui
org.eclipse.xtend.profiler
org.eclipse.xtend.shared.ui
org.eclipse.xtend.typesystem.emf
org.eclipse.xtend.typesystem.emf.ui
org.eclipse.xtend.typesystem.uml2
org.eclipse.xtend.typesystem.uml2.ui
org.eclipse.xtend.typesystem.xsd
org.eclipse.xtend.typesystem.xsd.ui
org.eclipse.xtend.ui
org.eclipse.xtend.util.stdlib


in this view

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Manifest error in project generator wizard [message #695501 is a reply to message #695500] Mon, 11 July 2011 21:59 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13613
Registered: July 2009
Senior Member
Hu? How was it possible that you installed Xtend without Xpand. There is only one Feature: Xpand SDK ~Christian

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Manifest error in project generator wizard [message #695503 is a reply to message #695501] Mon, 11 July 2011 22:00 Go to previous messageGo to next message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
That's a good question. Either way, the xpand engine is working for me as I am able to generate xml from my xpand template. I'm just installing Xpand now, i'll report back if it solves the problem. Regards, JD
Re: Manifest error in project generator wizard [message #695508 is a reply to message #695503] Mon, 11 July 2011 22:14 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13613
Registered: July 2009
Senior Member
If this does not work give a new clean eclipse installation or the itemis distro (http://download.itemis.com/distros/) a try

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Manifest error in project generator wizard [message #695514 is a reply to message #695508] Mon, 11 July 2011 22:31 Go to previous message
john doe is currently offline john doeFriend
Messages: 74
Registered: June 2011
Member
Installing Xpand SDK did the trick! Thanks for all the help,
Best Regards
JD
Previous Topic:Can't pick up a fully qualified class name
Next Topic:Testcoverage of a grammar
Goto Forum:
  


Current Time: Mon Sep 28 23:11:44 GMT 2020

Powered by FUDForum. Page generated in 0.02637 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top