Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Problem Shared Editing Domain
Problem Shared Editing Domain [message #694705] Sat, 09 July 2011 11:22 Go to next message
aurelienfaravelon is currently offline aurelienfaravelonFriend
Messages: 7
Registered: January 2011
Junior Member
Dear all,

I am experiencing a problem with the sharedEditingDomain.

Here is the principle : I have a single metamodel and two editors to edit models drawn out of two parts of it.

I made my editors with GMF and modified them according to the GMF tips to use a single EditingDomain

http://wiki.eclipse.org/Graphical_Modeling_Framework/Tips

as a result, if I modify my diagram in one editor, the other "sees" it as it displays its diagram as being modified. However, the result of the modification in one editor is not displayed in the other (for instance if I add a class shared by the two editors its is not visible) and when I switch from one editor to the other, Eclipse asks me if I want to load the changed applied to the file but even when I click "yes" nothing happens.

Could anyone help me?

Au.

PS : I am using Eclipse Helios on Fedora 14
Re: Problem Shared Editing Domain [message #695225 is a reply to message #694705] Mon, 11 July 2011 10:07 Go to previous message
Peter Mising name is currently offline Peter Mising nameFriend
Messages: 95
Registered: July 2009
Member
Hi,
maybe this is useful for you:
http://code.google.com/p/gmftools/wiki/SharedEditingDomain

Am Sa 09.07.11 13:22, schrieb forums-noreply@eclipse.org:
> Dear all,
>
> I am experiencing a problem with the sharedEditingDomain.
>
> Here is the principle : I have a single metamodel and two editors to
> edit models drawn out of two parts of it.
>
> I made my editors with GMF and modified them according to the GMF tips
> to use a single EditingDomain
> http://wiki.eclipse.org/Graphical_Modeling_Framework/Tips
>
> as a result, if I modify my diagram in one editor, the other "sees" it
> as it displays its diagram as being modified. However, the result of the
> modification in one editor is not displayed in the other (for instance
> if I add a class shared by the two editors its is not visible) and when
> I switch from one editor to the other, Eclipse asks me if I want to load
> the changed applied to the file but even when I click "yes" nothing
> happens.
>
> Could anyone help me?
> Au.
>
> PS : I am using Eclipse Helios on Fedora 14
Previous Topic:Create Element and Link
Next Topic:Need Help for Ocl Constraint
Goto Forum:
  


Current Time: Tue Mar 09 05:16:38 GMT 2021

Powered by FUDForum. Page generated in 0.02095 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top