Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » TomCat running from Eclipse shows old cached data
TomCat running from Eclipse shows old cached data [message #690191] Wed, 29 June 2011 06:50 Go to next message
dimmid is currently offline dimmidFriend
Messages: 4
Registered: June 2011
Junior Member
I have a peculiar problem working with Eclipse 3.6 and TomCat 7.

I'm developing a webapplication in JSF and been doing that for a little while now.

But now, all of a sudden, when i choose my project and goes
[right click]-->"Run As" --> "Run on Server"

...the newly edited xhtml data is showing old stuff on the web page.
I've tried to:
* Reinstall Eclipse
* Reinstall TomCat
* "Clean" choice on "Servers" in Eclipse.
* "Clean TomCat work directory" on "Servers" in Eclipse.

Nothing works.

I assume that Eclipse has som cache stored somewhere, that it doesn't matter what I'll do.

Anyone has any idea?
Re: TomCat running from Eclipse shows old cached data [message #690205 is a reply to message #690191] Wed, 29 June 2011 07:18 Go to previous messageGo to next message
dimmid is currently offline dimmidFriend
Messages: 4
Registered: June 2011
Junior Member
i.e.
this means that I'm standing still in my development as we speak.

EDIT:
lol...
I can even delete the whole page and still the old page shows!
Gaaah!!

[Updated on: Wed, 29 June 2011 07:38]

Report message to a moderator

Re: TomCat running from Eclipse shows old cached data [message #690231 is a reply to message #690205] Wed, 29 June 2011 08:24 Go to previous messageGo to next message
dimmid is currently offline dimmidFriend
Messages: 4
Registered: June 2011
Junior Member
Ok...

This is nuts!

I totally evaporated/killed/deleted the old project (including all files).
I started a new project with the same name as the one deleted.

I have a new start page which says something like "hello".

And guess what!!!
The same old cached data from the old deleted project is still presented in my browser!!!!!

I am clueless.

Now... someone here has any idea??
This should be concidered as a critical issue I think.
icon14.gif  Re: TomCat running from Eclipse shows old cached data [message #690382 is a reply to message #690231] Wed, 29 June 2011 12:58 Go to previous message
dimmid is currently offline dimmidFriend
Messages: 4
Registered: June 2011
Junior Member
Solution.

I had to clean the following map completely:

C:\Documents and Settings\[user]\Locale Settings\Temporary Internet Files\
Previous Topic:Can't get javax.swing.* and java.awt.* to weave
Next Topic:Update Site for Old Versions
Goto Forum:
  


Current Time: Sat Dec 16 20:42:23 GMT 2017

Powered by FUDForum. Page generated in 0.02156 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software