Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Adding Error Log view without depending on o.e.pde
Adding Error Log view without depending on o.e.pde [message #686617] Wed, 22 June 2011 15:41 Go to next message
Alex Kravets is currently offline Alex KravetsFriend
Messages: 561
Registered: November 2009
Senior Member
Hello,

In my RCP I want to include Error Log view, if I add dependency on org.eclipse.pde.runtime the view shows up, but I also get Run and Search menus which I don't want - I added o.e.pde into my target platform. I found this blog post that says that in 3.4+ error log view lives in org.eclipse.ui.views.log, is this in fact the case? I can't seem to add this plugin without having o.e.pde in target platform.

Thanks,
Alex
(no subject) [message #692572 is a reply to message #686617] Mon, 04 July 2011 18:45 Go to previous messageGo to next message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 423
Registered: July 2009
Senior Member
Hi Alex,

You need to isolate the Error log view. If the plugin depends on other
plugins that in turn pull in the complete PDE then you need to hack this
yourself. File a bug to ask for isolation of this view and if at all
possible, provide the patch as well.

Best regards,

Wim Jongman


> Hello,
>
> In my RCP I want to include Error Log view, if I add dependency on
org.eclipse.pde.runtime the view shows up, but I also get Run and Search
menus which I don't want - I added o.e.pde into my target platform. I found
http://aniszczyk.org/2007/10/08/error-log-view-and-you/ blog post that says
that in 3.4+ error log view lives in org.eclipse.ui.views.log, is this in
fact the case? I can't seem to add this plugin without having o.e.pde in
target platform.
>
> Thanks,
> Alex
Re: (no subject) [message #693608 is a reply to message #692572] Wed, 06 July 2011 21:02 Go to previous message
Alex Kravets is currently offline Alex KravetsFriend
Messages: 561
Registered: November 2009
Senior Member
Thanks Wim,

I took a look at o.e.ui.views.log again and don't see dependency on pde there (or any of its dependencies). I am going to look at this more closely, perhaps it was oversight on my part.

Alex
Previous Topic:Problems during export of a product
Next Topic:org.eclipse.ui.navigator.CommonNavigator
Goto Forum:
  


Current Time: Tue Dec 07 22:23:47 GMT 2021

Powered by FUDForum. Page generated in 0.01574 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top