Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Versions of OCL
Versions of OCL [message #67832] Thu, 11 January 2007 10:34 Go to next message
Conor Missing name is currently offline Conor Missing nameFriend
Messages: 159
Registered: July 2009
Senior Member
Hi,

I'm relatively new to Eclipse so am not too familiar with versions of
releases, etc.

I want to use a plugin that uses OCL, the version that is specified is EMF
OCL build 1.1M3, form the download page:

http://www.eclipse.org/emft/downloads/index.php?project=ocl& amp;showAll=0&showMax=5

all I can see is the M4 and M2 builds. Can I safely use a build that is
higher than the one specified?

If so, is this also true in general for builds etc in Eclipse?

Thanks, Gaff
Where can I get M3 version? [message #67851 is a reply to message #67832] Thu, 11 January 2007 11:20 Go to previous messageGo to next message
Conor Missing name is currently offline Conor Missing nameFriend
Messages: 159
Registered: July 2009
Senior Member
Looking at the requiremnents, it says that OCL M4 requires Eclipse
S-3.3M4, where as OCL M3 only Eclipse build S-3.3M3, which is what I'm
using, so I'd guess that M4 won't work?

Where can I get OCL M3? As it does not appear on the website I previoulsy
stated?
Re: Versions of OCL [message #68018 is a reply to message #67832] Thu, 11 January 2007 22:34 Go to previous message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

Hi, Gaff,

In the 1.1 release, OCL has moved to the Modeling Project. The newsgroup
for OCL has likewise moved to eclipse.modeling.mdt.uml2.ocl.

Downloads of OCL 1.1 are available at:

http://www.eclipse.org/modeling/mdt/downloads/?project=uml2- ocl

There you will find the 1.1M3 build as well as 1.1M4. I think it is a
mistake that 1.1M4 appears on the old EMFT downloads page.

Cheers,

Christian


Gaff wrote:

> Hi,
>
> I'm relatively new to Eclipse so am not too familiar with versions of
> releases, etc.
>
> I want to use a plugin that uses OCL, the version that is specified is EMF
> OCL build 1.1M3, form the download page:
>
>
http://www.eclipse.org/emft/downloads/index.php?project=ocl& amp;showAll=0&showMax=5
>
> all I can see is the M4 and M2 builds. Can I safely use a build that is
> higher than the one specified?
>
> If so, is this also true in general for builds etc in Eclipse?
>
> Thanks, Gaff
Where can I get M3 version? [message #601114 is a reply to message #67832] Thu, 11 January 2007 11:20 Go to previous message
Conor Missing name is currently offline Conor Missing nameFriend
Messages: 159
Registered: July 2009
Senior Member
Looking at the requiremnents, it says that OCL M4 requires Eclipse
S-3.3M4, where as OCL M3 only Eclipse build S-3.3M3, which is what I'm
using, so I'd guess that M4 won't work?

Where can I get OCL M3? As it does not appear on the website I previoulsy
stated?
Previous Topic:[teneo] Is Inheritance variant TABLE_PER_CLASS still unsupported
Next Topic:[Transactions] multiple editing domains for one resource set
Goto Forum:
  


Current Time: Sat Feb 27 22:50:53 GMT 2021

Powered by FUDForum. Page generated in 0.01706 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top