Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Simultaneous release » Not find spring jar sometime(Spring jar not find by eclipse when i run java web project in tomcat by eclipse IDE)
icon8.gif  Not find spring jar sometime [message #675237] Mon, 30 May 2011 21:01
manoj  is currently offline manoj Friend
Messages: 1
Registered: May 2011
Junior Member

I am very disappointed when i run my j2ee web project. I set up tomcat as a server and created a java web project and try to run it. Sometime it run smooth but sometime it is not able to pick simple spring jar file. When i create a war file of this project by Maven and place this jar in tomcate/webapps folder than its run fine. But when i try to run it by tomcat plugin in eclipse galileo i got below exception..

SEVERE: Error configuring application listener of class org.springframework.web.context.ContextLoaderListener
java.lang.ClassNotFoundException: org.springframework.web.context.ContextLoaderListener
at org.apache.catalina.loader.WebappClassLoader.loadClass(
at org.apache.catalina.loader.WebappClassLoader.loadClass(
at org.apache.catalina.core.StandardContext.listenerStart(
at org.apache.catalina.core.StandardContext.start(
at org.apache.catalina.core.ContainerBase.start(
at org.apache.catalina.core.StandardHost.start(
at org.apache.catalina.core.ContainerBase.start(
at org.apache.catalina.core.StandardEngine.start(
at org.apache.catalina.core.StandardService.start(
at org.apache.catalina.core.StandardServer.start(
at org.apache.catalina.startup.Catalina.start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.apache.catalina.startup.Bootstrap.start(
at org.apache.catalina.startup.Bootstrap.main(

Could you please suggest me what should i do for run it in eclipse...
Previous Topic:WebService Client (The service definition selected is invalid)
Next Topic:Ubuntu Natty: 32 bit JDK in Eclipse Galileo
Goto Forum:

Current Time: Fri Sep 24 00:43:26 GMT 2021

Powered by FUDForum. Page generated in 0.01415 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top