Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Java SWT x64 deploy problem
Java SWT x64 deploy problem [message #674764] Sat, 28 May 2011 10:58 Go to next message
Attila Hegedus is currently offline Attila HegedusFriend
Messages: 2
Registered: May 2011
Junior Member
Hello!

I'm trying to deploy a 64-bit version of my Java app using SWT with no success.

I compiled and exported the project into a JAR file on a 32-bit PC with 32-bit Java SDK and SWT Win x32. It worked perfectly.

Then I exported the project on a 64-bit PC with 64-bit Java SDK and SWT Win x64. When I tried to launch the executable JAR, nothing happened!

I tried the same with an SWT Hello World example. I experienced the same result.

What am I doing wrong? Thanks in advance!
Re: Java SWT x64 deploy problem [message #674786 is a reply to message #674764] Sat, 28 May 2011 13:38 Go to previous message
Attila Hegedus is currently offline Attila HegedusFriend
Messages: 2
Registered: May 2011
Junior Member
I fixed it! Both x86 and x64 JRE were installed, but the 32-bit version was set as default...

[Updated on: Sat, 28 May 2011 13:40]

Report message to a moderator

Previous Topic:Add an action to a CLabel
Next Topic:SWT Tree Item with two Images , is it possible
Goto Forum:
  


Current Time: Sat Feb 29 08:16:11 GMT 2020

Powered by FUDForum. Page generated in 0.08196 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top