Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » DND images and offset not working?
DND images and offset not working? [message #668161] Wed, 04 May 2011 08:47 Go to next message
Eclipse UserFriend
Originally posted by: flo.redflo.de

Hi,

i can set the image in DragStart() and it gets displayed. But the left
top corner of the image is the mouse pointer center. This confuses users
whenever they want to place the image somewhere. I tried to set
event.offsetX and offsetY but that had no effect. Can i set the center
of the image to the center of the mouse pointer?

Im using swt from Eclipse Helios Service Release 2 on linux 64bit.

Thanks for help!
Re: DND images and offset not working? [message #668370 is a reply to message #668161] Thu, 05 May 2011 13:25 Go to previous message
Lakshmi ShanmugamFriend
Messages: 276
Registered: July 2009
Location: India
Senior Member
Hi,

This looks like a bug on Linux. It works fine on my Windows machine. Please open a bug with SWT here--> https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform &component=SWT

Thanks.


Lakshmi P Shanmugam
Previous Topic:Browser and Webkit GTK 1.3
Next Topic:Possible to clone browser control?
Goto Forum:
  


Current Time: Sat Dec 05 09:40:29 GMT 2020

Powered by FUDForum. Page generated in 0.01563 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top