Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » MoDisco » MoDisco 0.8 Java Code Generation(Generate Code from javaxmi model (AbstractAcceleoGenerator))
MoDisco 0.8 Java Code Generation [message #664494] Sat, 09 April 2011 22:11 Go to next message
Rob is currently offline RobFriend
Messages: 17
Registered: February 2011
Junior Member
Hi guys!

I am trying to do code generation with MoDisco/Acceleo using Generate_JavaStructure with MoDisco 0.8/Helios.

I created an Acceleo Plugin-Project and added the dependency to the package.
After that I created a Run Configuration pointing to the Generate_JavaStructure class and the javaxmi model I preliminary created from the reverse engineering tool with modisco.

This is at least what I get from
http:// ava_Generation.

But running the Configuration on the model I get no output or results.

I tried to use the model within a test installation based on Indigo and MoDisco 0.9 with the context entry to create java code from model, which works for the model.

But I don't want to switch to the non final versions of my tools in the middle of the project.

I would appreciate it if anybody has an explanation for this problem.

using: MoDisco 0.8.2, Acceleo 3.0.2

Some additional information:

I opend my workspace in latest Milestone of Indigo with MoDisco 0.9 and did the same Run Configuration there and it worked.
I noticed the difference, that the Generate_JavaStructure class in 0.8.2 is not a subclass of AbstractAcceleoGenerator whereas in 0.9 the deprecated one and GenerateJavaExtended are subclasses.

According to Acceleo Documentation the Generator must extend AbstractAcceleoGenerator to work.

Have there been any changes in Acceleo Versions which require this subclassing now?

many thx in advance

[Updated on: Sun, 10 April 2011 12:20]

Report message to a moderator

Re: MoDisco 0.8 Java Code Generation [message #665081 is a reply to message #664494] Wed, 13 April 2011 08:18 Go to previous message
Fabien Giquel is currently offline Fabien GiquelFriend
Messages: 147
Registered: July 2009
Senior Member
Hi Rob,

with the steps you describes, it should work on MoDisco0.8.2.

Do you have any error in error log when launching your acceleo
configuration ?
Do you use the "Acceleo Plug-in Application" in "Runner" combobox of
your Acceleo launch config (it is the default choice) ?


R&D Engineer
rue Nina Simone
44000 NANTES
Previous Topic:[ATL] Run Modisco .javaxmi transformation programmatically
Next Topic:MoDisco changing Model Load behavior
Goto Forum:

Current Time: Wed Dec 02 00:30:35 GMT 2020

Powered by FUDForum. Page generated in 0.01553 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top