Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Compare with...
Compare with... [message #66033] Wed, 13 February 2008 14:04 Go to next message
Eclipse UserFriend
Originally posted by: tatsudoshi.criion.net

Hi, I having problems using the 'Compare with...' function.

I am running eclipse pdt

Version: 3.3.1.1
Build id: M20071023-1652

and rse to connect to the files (php)

The 'Local History' works fine. The 'Each Other' is grayed out.

How do I compare to files of the same filename, but on different remote
locations?
Re: Compare with... [message #66076 is a reply to message #66033] Wed, 13 February 2008 15:53 Go to previous messageGo to next message
D Kelsey is currently offline D KelseyFriend
Messages: 232
Registered: July 2009
Senior Member
Is it only PHP files that you find the compare with each other is grayed out or does it happen for
any file. This could be an issue with RSE rather than PDT.

Dave Kelsey

tatsudoshi wrote:
> Hi, I having problems using the 'Compare with...' function.
>
> I am running eclipse pdt
>
> Version: 3.3.1.1
> Build id: M20071023-1652
>
> and rse to connect to the files (php)
>
> The 'Local History' works fine. The 'Each Other' is grayed out.
>
> How do I compare to files of the same filename, but on different remote
> locations?
Re: Compare with... [message #66096 is a reply to message #66033] Wed, 13 February 2008 15:54 Go to previous messageGo to next message
drm / Gerard is currently offline drm / GerardFriend
Messages: 26
Registered: July 2009
Junior Member
tatsudoshi wrote:
> How do I compare to files of the same filename, but on different remote
> locations?

Can't you ctrl-click the files successively and then right-click ->
Compare with ... -> Each other? Or do the files appear in different views?
Re: Compare with... [message #66140 is a reply to message #66096] Thu, 14 February 2008 08:35 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: tatsudoshi.criion.net

Ahh yes this worked! So simple yet so elusive ;-)

I was trying to open the two files and expecting 'Each Other' to light
up then or something 'to happen' hehe.

Thanks for the help guys
Re: Compare with... [message #66159 is a reply to message #66033] Thu, 14 February 2008 08:46 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: tatsudoshi.criion.net

A little side question:

It opens up in 'Default Compare Editor' in 'Text Compare'.

Is it possible to set it to use PHP highlighting?
Re: Compare with... [message #66769 is a reply to message #66159] Tue, 26 February 2008 00:03 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: pim.parse.nl

tatsudoshi wrote:
> A little side question:
> It opens up in 'Default Compare Editor' in 'Text Compare'.
> Is it possible to set it to use PHP highlighting?

This is a bug in PDT 1.0.2 afaik, I think the relevant bug report is:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=203529

You can probably manually apply the patch yourself if you can open/edit
jar files, as the change is only in the plugin.xml file. Or use a nightly
build.
Re: Compare with... [message #66792 is a reply to message #66769] Tue, 26 February 2008 12:51 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: tatsudoshi.criion.net

Ah thanks mate
Re: Compare with... [message #66805 is a reply to message #66769] Tue, 26 February 2008 13:16 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: tatsudoshi.criion.net

Can I just take the <org.eclipse.php.ui_>.jar and replace the one in pdt
1.0.2 R or should I use the entire nightly?
Re: Compare with... [message #66858 is a reply to message #66805] Tue, 26 February 2008 14:21 Go to previous messageGo to next message
D Kelsey is currently offline D KelseyFriend
Messages: 232
Registered: July 2009
Senior Member
Apparently the 1.0.2 nightly build is taken from the HEAD branch which is actually the 1.1 (1.5)
nightly build, so I would suggest you don't take any part of the nightly build as this is targeted
at the eclipse 3.4 level.

Dave Kelsey

tatsudoshi wrote:
> Can I just take the <org.eclipse.php.ui_>.jar and replace the one in pdt
> 1.0.2 R or should I use the entire nightly?
Re: Compare with... [message #66874 is a reply to message #66858] Wed, 27 February 2008 11:05 Go to previous message
Eclipse UserFriend
Originally posted by: tatsudoshi.criion.net

Yea I tried but PDT wouldn't start with it.

I'll just wait for the release. It's not a real problem per say...

Thanks for the help everyone
Previous Topic:debug entire site
Next Topic:More than one client host for xdebugger and problem with zend debugger
Goto Forum:
  


Current Time: Mon Jan 30 12:45:23 GMT 2023

Powered by FUDForum. Page generated in 0.04406 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top