Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » How to deal with org.osgi.framework.system.packages.extra packages?
How to deal with org.osgi.framework.system.packages.extra packages? [message #657908] Fri, 04 March 2011 15:03
Ben  is currently offline Ben Friend
Messages: 2
Registered: February 2011
Junior Member
I'm developing a bundle that uses packages that are specific to the version of the JRE - in particular, the JZOS packages that come with the IBM JRE for z/OS. In order to make these packages exported by the system bundle, I have to add them to the org.osgi.framework.system.packages.extra property of the framework and ensure my bundle imports them, and it all works fine. Cool

However, I'm having difficulty creating a project in PDE that will compile with this in mind.

I've copied the JZOS JAR into my project - it's needed purely for compilation purposes, so I've added it to my build.properties (jars.extra.classpath = ibmjzos.jar) and it compiles fine, but when I come to Export -> Deployable Plugins and Fragments I get an error saying:

Processing inclusion from feature org.eclipse.pde.container.feature: Bundle test.jzos_1.0.0 failed to resolve.:
Unsatisfied import package com.ibm.jzos_0.0.0.

The only solution I've found is to make sure that my manifest specifies resolution:=optional on the Import-Package statement... but I don't want it to be optional - it's a prereq for my bundle!

Any ideas?
Previous Topic:Move WorkbenchWindow to a virtual desktop on KDE
Next Topic:Uninstalling and Deleting plug-ins from eclipse
Goto Forum:
  


Current Time: Wed Aug 12 14:38:27 GMT 2020

Powered by FUDForum. Page generated in 0.01718 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top