Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Updating Papyrus(Problems updating to stable build 0.8.0)
Updating Papyrus [message #651761] Tue, 01 February 2011 13:49 Go to next message
Markus Lorenz is currently offline Markus LorenzFriend
Messages: 11
Registered: August 2010
Junior Member
Hey guys,

I'm currently working with Papyrus 0.7.0 and I would like to update to stable build 0.8.0. The problem is, that Eclipse is complaining about missing dependencies all the time. Each time it's a different one and when I try to get the missing component, there are even more dependencies which are needed. I've been trying for several hours and can't see how this should work out.

How do you update your Papyrus? Don't you have the same problems? Can you tell me what I'm doing wrong?

Could you please add a list of "Build Dependencies" to the release, like it's done for example at GMF: http://www.eclipse.org/modeling/gmp/downloads/?project=gmf-r untime

Thanks
Markus
Re: Updating Papyrus [message #651763 is a reply to message #651761] Tue, 01 February 2011 13:59 Go to previous messageGo to next message
Remi Schnekenburger is currently offline Remi SchnekenburgerFriend
Messages: 168
Registered: July 2009
Location: Palaiseau, France
Senior Member
Hi,

First of all, I would advise you not to switch to the 0.8.0 version, which aims the next major version of Eclipse (Indigo).
Current version 0.7.2 should be the most stable version of the tool, as it is based on helios current version of Eclipse platform.
If you really want to have test for Papyrus 0.8.0 M4, the easiest is to download the Eclipse modeling package Indigo M4, and install Papyrus from this package. This should be the easiest way. Note that the discovery UI (Install Modeling Components) has not been updated and still targets Papyrus 0.7.2 version in the Package modeling for Indigo. You have to enter the following adress in the install new software interface: http://download.eclipse.org/modeling/mdt/papyrus/updates/mil estones/0.8/

The tool we are currently using for Papyrus build does not allow us to retrieve and display automatically dependencies as it is done in GMF build system. I should write a small script that retrieves this from the build system, but unfortunately, I have many other things to do currently :/

Cheers,
Rémi




Remi Schnekenburger

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Updating Papyrus [message #651768 is a reply to message #651761] Tue, 01 February 2011 14:21 Go to previous messageGo to next message
Markus Lorenz is currently offline Markus LorenzFriend
Messages: 11
Registered: August 2010
Junior Member
Hey Rémi,

thank you very much for your quick and helpful answer. Smile

I tried installing Eclipse Modeling Indigo and Papyrus 0.8.0, but I still had some dependency problems. This could have been the discovery UI you mentioned.

Ok, then I'll try to use 0.7.2 for now. Are you refering to the newest nightly build of 0.7.2, N201101140616?

Thanks again
Markus
Re: Updating Papyrus [message #651770 is a reply to message #651768] Tue, 01 February 2011 14:27 Go to previous messageGo to next message
Remi Schnekenburger is currently offline Remi SchnekenburgerFriend
Messages: 168
Registered: July 2009
Location: Palaiseau, France
Senior Member
I am referring to the version R201101190547 (2011/01/19). this is the stable release 0.7.2 for Papyrus.

The download page is generated automatically from what is present on the server, I should clean a bit what is displayed, so this would be far easier for users to read this page Wink

Cheers
Rémi


Remi Schnekenburger

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Updating Papyrus [message #651772 is a reply to message #651761] Tue, 01 February 2011 14:40 Go to previous messageGo to next message
Markus Lorenz is currently offline Markus LorenzFriend
Messages: 11
Registered: August 2010
Junior Member
I found the newest version of 0.7.2 by using the "Sort: By Date" link from the right sidebar.

Thanks a lot!
Re: Updating Papyrus [message #651780 is a reply to message #651761] Tue, 01 February 2011 15:25 Go to previous messageGo to next message
Markus Lorenz is currently offline Markus LorenzFriend
Messages: 11
Registered: August 2010
Junior Member
Well, I'm sorry to bother you again. But the dependency problems are still troubling me.

During the installation of Papyrus-Update-R201101190547 I needed "org.eclipse.emd.ecore 2.6.1". I downloaded emf-xsd-Update-2.6.1 and tried to install it. There was an error message telling me that some RAP-Components were only for plugin development. I deselected them and successfully installed the rest of the package.

When trying to install Papyrus-Update-R201101190547 again I get the missing dependency notification "org.apache.xml.resolver 1.2.0". Sadly I don't have any clue how to get this into Eclipse, as it doesn't seem to be an Eclipse package at all, but a part of Apache Commons.

Do you have any idea how to solve this? Or any thoughts about why I'm having all this trouble?

Markus
Re: Updating Papyrus [message #651782 is a reply to message #651780] Tue, 01 February 2011 15:31 Go to previous messageGo to next message
Remi Schnekenburger is currently offline Remi SchnekenburgerFriend
Messages: 168
Registered: July 2009
Location: Palaiseau, France
Senior Member
No problem, forums are there for help Wink

It would be much more easier for you to install papyrus using the installation manager rather than from the zipped update site. (Follow instruction from the page http://www.eclipse.org/modeling/mdt/papyrus/updates/index.ph p

Otherwise, the bundle you mention are coming from the ORBIT project, which is the project where Eclipse put the required bundles that do not fit the EPL license (to summarize).
You can download the required bundle using the following URL: http://download.eclipse.org/tools/orbit/downloads/drops/R201 00519200754/repository

HTH,
Rémi


Remi Schnekenburger

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Updating Papyrus [message #651787 is a reply to message #651761] Tue, 01 February 2011 15:44 Go to previous message
Markus Lorenz is currently offline Markus LorenzFriend
Messages: 11
Registered: August 2010
Junior Member
Yeh, I guess it would be less troubling to use the installation manager. Sadly the computer with internet access at my working place is restricted in a way, that I can't install all the software I need. For security reasons. And the private notebook I'm using isn't allowed to use the network to get internet access. Again for security reasons, you know ...

Next time I should definitely try updating at home. Smile
Previous Topic:Model Explorer Customization Question
Next Topic:Activity Diagram partitions?
Goto Forum:
  


Current Time: Mon Jan 27 14:59:49 GMT 2020

Powered by FUDForum. Page generated in 0.02168 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top