Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Cannot select more than one object in diagram(Using the papyrus diagram editor, only one element at a time can be selected. This prevents using many functions that deal with a set of elements)
icon5.gif  Cannot select more than one object in diagram [message #651557] Mon, 31 January 2011 16:16 Go to next message
Michael Theurich is currently offline Michael TheurichFriend
Messages: 3
Registered: July 2010
Junior Member
Hi,
I have installed MDT Papyrus - plugins 0.7.2.v201101191114 org.eclipse.papyrus.xxxx onto a eclipse helios 3.6.1 running on Windows XP

On the diagram editor (PapyrusMultiDiagramEditor), I can create all sorts of elements as expected. But what I cannot do is select more than one element. Whenever I try, the multiple selection is first indicated (by filled squares on the principal element and open squares on all others). The method for selecting does not matter, shift-click, ctrl-click, shift-move (marquee), all prduce the same result: only one selected element remains. Due to this problem, I cannot align elements or make adjustments to a set etc.

I can well select multiple elements in the model explorer or in other graphical editor plugins.

I know it is very difficult to help me with that, how can I describe all other relevant conditions which may have led to the problem. I have searched this forum and the internet, this seems to be an unknown problem.

Maybe I can disable some of the smart mouse-over usability enhancements?

Does anybody have any idea? I am hapy to provide more details about my configuration if needed.

Thanks in advance.

Michael
Re: Cannot select more than one object in diagram [message #651560 is a reply to message #651557] Mon, 31 January 2011 16:22 Go to previous messageGo to next message
Remi Schnekenburger is currently offline Remi SchnekenburgerFriend
Messages: 168
Registered: July 2009
Location: Palaiseau, France
Senior Member
Hi,

I think your bug is a known one and is tied to the model explorer synchronization mode. On top right corner of the model explorer, you have a double arrow button which can be activated or not.
This button activates the synchronization of the selection between the model explorer and the views in the diagram. It causes bugs for multi-selection.
You can look at Bug 333982: [All diagrams] Multiple selection not working when "Link with Editor" is activated
https://bugs.eclipse.org/bugs/show_bug.cgi?id=333982

If the synchronize mode is not activated, the bug should not be present.

HTH
Rémi


Remi Schnekenburger

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Cannot select more than one object in diagram [message #651562 is a reply to message #651557] Mon, 31 January 2011 16:28 Go to previous messageGo to next message
Michael Theurich is currently offline Michael TheurichFriend
Messages: 3
Registered: July 2010
Junior Member
Wow, that's what I call a super-fast answer. Yes, disabling the link button solved the problem. I hope this is linked mode is not otherwise required.

Thanks a lot. Smile
Re: Cannot select more than one object in diagram [message #651563 is a reply to message #651562] Mon, 31 January 2011 16:30 Go to previous message
Remi Schnekenburger is currently offline Remi SchnekenburgerFriend
Messages: 168
Registered: July 2009
Location: Palaiseau, France
Senior Member
No, the link mode is never required somewhere else, this is just an ergonomic functionality. This should help users when dealing with great models Wink

Cheers
Rémi


Remi Schnekenburger

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Previous Topic:drag elements from the model view, don`t show the profile stereotypes.
Next Topic:class diagram from java via modisco
Goto Forum:
  


Current Time: Tue Jan 21 21:33:49 GMT 2020

Powered by FUDForum. Page generated in 0.02489 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top