Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EEF] Absolute paths in components model
[EEF] Absolute paths in components model [message #650337] Mon, 24 January 2011 12:48 Go to next message
Nirmal SasidharanFriend
Messages: 120
Registered: July 2009
Location: Germany
Senior Member
Hello,

EEF initialized components model seems to reference gemodel with absolute file URIs.

<model href="file:/absolutepath/model.genmodel#//fragment"/>

This is making the initialized models less portable. Since EEF architecture initialization is always confined to the current workspace, why not use relative references?

Please let me know if I should add a bugzilla entry for this?

Regards,
Nirmal
Re: [EEF] Absolute paths in components model [message #650365 is a reply to message #650337] Mon, 24 January 2011 16:05 Go to previous message
Goulwen Le Fur is currently offline Goulwen Le FurFriend
Messages: 125
Registered: July 2009
Senior Member
Hello,


This must also be fixed in last 0.9 version. Let me know if this is
fixed in your last nighlty version.

--
Goulwen

Le 24/01/2011 13:48, Nirmal Sasidharan a écrit :
> Hello,
>
> EEF initialized components model seems to reference gemodel with
> absolute file URIs.
>
> <model href="file:/absolutepath/model.genmodel#//fragment"/>
>
> This is making the initialized models less portable. Since EEF
> architecture initialization is always confined to the current workspace,
> why not use relative references?
> Please let me know if I should add a bugzilla entry for this?
>
> Regards,
> Nirmal
Previous Topic:[EMF Compare] Cannot open emfdiff file
Next Topic:ChangeCommand Test
Goto Forum:
  


Current Time: Sun Oct 25 17:46:42 GMT 2020

Powered by FUDForum. Page generated in 0.02159 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top