Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Teneo source bundles containing plugin.xml(Teneo source bundles containing plugin.xml)
Teneo source bundles containing plugin.xml [message #650017] Fri, 21 January 2011 13:32 Go to next message
Fabian is currently offline FabianFriend
Messages: 4
Registered: February 2010
Junior Member
Hi,

I have a problem during execution of plug-in tests via maven/tycho. If the tests starts and therefore all plug-ins will be loaded, there are warnings like this:

*****************
!ENTRY org.eclipse.emf.ecore 2 0 2011-01-21 14:16:16.375
!MESSAGE Both 'org.eclipse.emf.teneo.hibernate.mapper' and 'org.eclipse.emf.teneo.hibernate.mapper.source' register a package for 'http://www.eclipse.org/emf/teneo/2006/HbAnnotation'

!ENTRY org.eclipse.emf.ecore 2 0 2011-01-21 14:16:16.375
!MESSAGE Both 'org.eclipse.emf.teneo.hibernate.mapper' and 'org.eclipse.emf.teneo.hibernate.mapper.source' register a package for 'http://www.eclipse.org/emf/teneo/2006/HbModel'
*****************

The problem seems that some of the teneo hibernate source bundles contains the plugin.xml and if they get loaded they wrongly overwrite the registration of the binary plug-in.

Is this a bug of the packaging of the source bundles?

Fabian
Re: Teneo source bundles containing plugin.xml [message #650052 is a reply to message #650017] Fri, 21 January 2011 14:32 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hmm, yes this seems to be a bug. I will do a new Teneo build this weekend with some fixes, I will also handle this one.

gr. Martin

On 01/21/2011 02:33 PM, Fabian wrote:
> Hi,
>
> I have a problem during execution of plug-in tests via maven/tycho. If the tests starts and therefore all plug-ins will
> be loaded, there are warnings like this:
>
> *****************
> !ENTRY org.eclipse.emf.ecore 2 0 2011-01-21 14:16:16.375
> !MESSAGE Both 'org.eclipse.emf.teneo.hibernate.mapper' and 'org.eclipse.emf.teneo.hibernate.mapper.source' register a
> package for 'http://www.eclipse.org/emf/teneo/2006/HbAnnotation'
>
> !ENTRY org.eclipse.emf.ecore 2 0 2011-01-21 14:16:16.375
> !MESSAGE Both 'org.eclipse.emf.teneo.hibernate.mapper' and 'org.eclipse.emf.teneo.hibernate.mapper.source' register a
> package for 'http://www.eclipse.org/emf/teneo/2006/HbModel'
> *****************
>
> The problem seems that some of the teneo hibernate source bundles contains the plugin.xml and if they get loaded they
> wrongly overwrite the registration of the binary plug-in.
>
> Is this a bug of the packaging of the source bundles?
>
> Fabian


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo source bundles containing plugin.xml [message #653534 is a reply to message #650052] Thu, 10 February 2011 07:57 Go to previous messageGo to next message
Fabian is currently offline FabianFriend
Messages: 4
Registered: February 2010
Junior Member
Is there already a newer build available? I looked at http://download.eclipse.org/modeling/emf/teneo/updates/1.2.0 /interim/ and found only the version "1.1.2.v201101061255".

Fabian
Re: Teneo source bundles containing plugin.xml [message #653629 is a reply to message #653534] Thu, 10 February 2011 13:30 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi,
I have not had time yet, I have had some build/test problems... Next week hopefully as I will have more time to work on
Teneo and some open issues.

gr. Martin

On 02/10/2011 08:57 AM, Fabian wrote:
> Is there already a newer build available? I looked at
> http://download.eclipse.org/modeling/emf/teneo/updates/1.2.0 /interim/ and found only the version "1.1.2.v201101061255".
>
> Fabian


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo source bundles containing plugin.xml [message #655442 is a reply to message #653534] Mon, 21 February 2011 07:03 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
I published a new build which should solve this (and some other issues).

gr. Martin

On 02/10/2011 08:57 AM, Fabian wrote:
> Is there already a newer build available? I looked at
> http://download.eclipse.org/modeling/emf/teneo/updates/1.2.0 /interim/ and found only the version "1.1.2.v201101061255".
>
> Fabian


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Previous Topic:emf model query
Next Topic:MinimalEObjectImpl and boolean flags
Goto Forum:
  


Current Time: Tue Oct 15 11:01:50 GMT 2019

Powered by FUDForum. Page generated in 0.02061 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top