Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » Couldn't find operation "!=(Void)" for stereotype's property
icon5.gif  Couldn't find operation "!=(Void)" for stereotype's property [message #649272] Tue, 18 January 2011 14:27 Go to next message
Tom Brandenburg is currently offline Tom BrandenburgFriend
Messages: 58
Registered: October 2010
Location: Abstatt, Germany
Member
Hello everyone,

in my m2m-project which converts an UML model to an Ansi-C model, I use an UML profile to extend the UML model. In the Xtend code I want to check if a property (defined in the profile) is set with "!= null". But the editor says that it couldn't find an operation "!=(Void)" for the property. Since the execution of the script works I can't really understand this error message.

Here you can see the definition in the profile:
http://fcg.km23412-02.keymachine.de/ftp/upload/test/profile.jpg

And here the error message in the Xtend script:
http://fcg.km23412-02.keymachine.de/ftp/upload/test/null.jpg

Do you have any idea?

Thanks in advance and best regards
Tom Smile
Re: Couldn't find operation "!=(Void)" for stereotype's property [message #649661 is a reply to message #649272] Thu, 20 January 2011 07:32 Go to previous message
Tom Brandenburg is currently offline Tom BrandenburgFriend
Messages: 58
Registered: October 2010
Location: Abstatt, Germany
Member
Is this the right newsgroup for it? Smile
Previous Topic:*ToEcore: How to create primitive types
Next Topic:[ATL] Using *.profile.uml files
Goto Forum:
  


Current Time: Wed Jun 19 09:08:26 GMT 2019

Powered by FUDForum. Page generated in 0.01418 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top