Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Project at the root of a Network Share does not display files
Project at the root of a Network Share does not display files [message #638822] Fri, 12 November 2010 16:47 Go to next message
rpcann is currently offline rpcannFriend
Messages: 2
Registered: November 2010
Junior Member
When creating a new General Project in Eclipse, the contents of the project do not appear if the location of the project is set to be the root of a Windows share. In addition, the Properties view says that the "Resource does not exist". If I set the location of the project one folder down from the root, the problem doesn't occur. If I map a drive to that location, the problem doesn't occur.

Additionally if I drag a file from another project, the file will appear, but as soon as I refresh it does not appear in the navigator and Eclipse prompts me to delete the project.

I saw this problem in my RCP application which is built from Eclipse 3.4.0, but I tested it in clean downloads of Eclipse without my application (3.4.0, 3.4.2, 3.5.0, and 3.6.1 - All Windows 32bit). They all have the same issue. I searched through buzilla and couldn't find this issue. Is this a bug? Or is there something I am not doing correctly?

To replicate the problem:
- Create a General Project with the default location
- Create a General Project to the root directory of a Windows share ex //machine/sharename
- Look at the properties of the remote project (See the error message)
- In the local project create a text file
- Drag the text file from the local project to the project on the share
- Refresh the network share project
- Eclipse should complain about the project location not existing.
- Also observe that the file is actually in the network share location despite Eclipse not seeing it anymore.
Re: Project at the root of a Network Share does not display files [message #638854 is a reply to message #638822] Fri, 12 November 2010 18:37 Go to previous messageGo to next message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

rpcann wrote:
>
> To replicate the problem:
> - Create a General Project with the default location
> - Create a General Project to the root directory of a Windows share ex
> //machine/sharename
> - Look at the properties of the remote project (See the error message)
> - In the local project create a text file
> - Drag the text file from the local project to the project on the share
> - Refresh the network share project
> - Eclipse should complain about the project location not existing. -
> Also observe that the file is actually in the network share location
> despite Eclipse not seeing it anymore.

I'd open a bug at
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform &component=Resources

PW


--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Platform_Expression_Framework
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


Re: Project at the root of a Network Share does not display files [message #638857 is a reply to message #638854] Fri, 12 November 2010 19:03 Go to previous message
rpcann is currently offline rpcannFriend
Messages: 2
Registered: November 2010
Junior Member
Thank you for the feedback. Submitted under Bug 330128.
Previous Topic:Linked projects, missing dependecies error
Next Topic:[Debug Platform] Stack Frame doesn't get focus
Goto Forum:
  


Current Time: Thu Jan 21 19:25:41 GMT 2021

Powered by FUDForum. Page generated in 0.01914 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top