Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Not getting Instance of IResource
Not getting Instance of IResource [message #64283] Mon, 08 June 2009 13:44 Go to next message
Shrijeet is currently offline ShrijeetFriend
Messages: 14
Registered: July 2009
Junior Member
Was just trying out some example. I want to create a trigger point at
instance of IResource. However when I declare this instance in the
plugin.xml I get error as "org.eclipse.core.resources.IResource" in
attribute "value" is not in the plug-in classpath.

below is the snippet of my xml

<triggerPoints>
<or>
<and>
<instanceof
value="org.eclipse.core.resources.IResource">
</instanceof>
<test
forcePluginActivation="true"
property="org.eclipse.core.resources.extension"
value="properties">
</test>
</and>
<instanceof

value="com.eclipse.ui.dagger.navigator.PropertiesTreeData">
</instanceof></or>
</triggerPoints>

Does this mean the IResource package is not available in my eclipse
installation?
Re: Not getting Instance of IResource [message #64306 is a reply to message #64283] Mon, 08 June 2009 13:59 Go to previous message
Shrijeet is currently offline ShrijeetFriend
Messages: 14
Registered: July 2009
Junior Member
Got it.. Please Ignore
Re: Not getting Instance of IResource [message #598153 is a reply to message #64283] Mon, 08 June 2009 13:59 Go to previous message
Shrijeet is currently offline ShrijeetFriend
Messages: 14
Registered: July 2009
Junior Member
Got it.. Please Ignore
Previous Topic:Not getting Instance of IResource
Next Topic:ClassNotFoundException when running Java application inside PDE project
Goto Forum:
  


Current Time: Thu Jun 17 19:05:15 GMT 2021

Powered by FUDForum. Page generated in 0.01711 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top