Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] ASMModul not found in ATL 2.0
[ATL] ASMModul not found in ATL 2.0 [message #64243] Thu, 18 October 2007 12:02 Go to next message
Jens von Pilgrim is currently offline Jens von PilgrimFriend
Messages: 313
Registered: July 2009
Senior Member
Hi all,

I'm using ATL programmatically by using a Java class based on Denis
Waagelar's command line tool (see
http://ssel.vub.ac.be/svn-gen/UML1CaseStudies/uml1cs-atlcomm andline/src/org/atl/commandline/Main.java).

This

code uses org.atl.engine.vm.nativelib.ASMModel and
org.atl.engine.repositories.emf4atl.ASMEMFModel. With ATL Version 1.0,
the code compiled, but with ATL 2.0. both classes are not found. Of
course the package names were changed, but these classes are not found
anymore. ASMModel is now found in plugin
org.eclipse.m2m.atl.engine.vm_2.0.0. My plugin defines this plugin as a
required plugin, but apparently the classes of this plugin are not
found. The same is true for ASMEMFModel, which is now found in plugin
org.eclipse.m2m.atl.drivers.emf4atl_2.0.0.

As far as I understand the manifest files, the classes are exported. Is
it possible that a plugin cannot use classes of another plugin which
are not part of a jar? Did anyone else found the same problem, too?

Jens
Re: [ATL] ASMModul not found in ATL 2.0 [message #64399 is a reply to message #64243] Mon, 22 October 2007 14:12 Go to previous message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------060400080506050307060200
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 8bit

Hello,

There may be a bug into the exported plugins, you can submit it on this
page :
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=M2M

When I test with the source plugins it works. So you can try to :
1) get ATL source code for emf4atl and vm plugins
2) export them into jar files
3) use these jars as libraries into your commandline plugin

Of course it is a temporary solution, waiting for a best solution.

Regards,
William Piers

Jens v.P. a écrit :
> Hi all,
>
> I'm using ATL programmatically by using a Java class based on Denis
> Waagelar's command line tool (see
> http://ssel.vub.ac.be/svn-gen/UML1CaseStudies/uml1cs-atlcomm andline/src/org/atl/commandline/Main.java).
>
>
> This
> code uses org.atl.engine.vm.nativelib.ASMModel and
> org.atl.engine.repositories.emf4atl.ASMEMFModel. With ATL Version 1.0,
> the code compiled, but with ATL 2.0. both classes are not found. Of
> course the package names were changed, but these classes are not found
> anymore. ASMModel is now found in plugin
> org.eclipse.m2m.atl.engine.vm_2.0.0. My plugin defines this plugin as a
> required plugin, but apparently the classes of this plugin are not
> found. The same is true for ASMEMFModel, which is now found in plugin
> org.eclipse.m2m.atl.drivers.emf4atl_2.0.0.
>
> As far as I understand the manifest files, the classes are exported. Is
> it possible that a plugin cannot use classes of another plugin which are
> not part of a jar? Did anyone else found the same problem, too?
>
> Jens
>

--------------060400080506050307060200
Content-Type: text/x-vcard; charset=utf-8;
name="william.piers.vcf"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="william.piers.vcf"

YmVnaW46dmNhcmQNCmZuOldpbGxpYW0gUGllcnMNCm46UGllcnM7V2lsbGlh bQ0Kb3JnOk9i
ZW8NCmFkcjoyIHJ1ZSBSb2JlcnQgU2NodW1hbm47O2xvdCAyNDtOQU5URVM7 OzQ0NDA4O0Zy
YW5jZQ0KZW1haWw7aW50ZXJuZXQ6d2lsbGlhbS5waWVyc0BvYmVvLmZyDQp0 aXRsZTpNREEg
Q29uc3VsdGFudA0KdGVsO3dvcms6KzMzICgwKTIgNTEgMTMgNTEgODINCnRl bDtjZWxsOisz
MyAoMCk2IDIwIDMxIDc1IDk4DQp1cmw6aHR0cDovL3d3dy5vYmVvLmZyDQp2 ZXJzaW9uOjIu
MQ0KZW5kOnZjYXJkDQoNCg==
--------------060400080506050307060200--
Previous Topic:[ATL][UML] Superimposition Exception "Pattern not equal for execution environment and module in
Next Topic:QVT timelines
Goto Forum:
  


Current Time: Wed Apr 14 17:05:40 GMT 2021

Powered by FUDForum. Page generated in 0.02166 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top