Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » problem with UML2.ecore file
problem with UML2.ecore file [message #626963] Mon, 29 September 2008 13:20
Eclipse UserFriend
Originally posted by: jihed.touzi.enstimac.fr

Hi to all;
I'm working into a transformation that starts from a stereotyped UML2
model to genrate another DSL.
It works fine when in the metamodel field in the configuration panel i
specify it using NS URI: uri:http://www.eclipse.org/uml2/2.0.0/UML or
uri:http://www.eclipse.org/uml2/2.1.0/UML

The problem is when i use the physical UML2.ecore file of the same
version it doesn't works.

I obtain at first warnings like that:
ATTENTION: metamodel contains several classifiers with same name: EAttribute
ATTENTION: metamodel contains several classifiers with same name:
ecore::EAttribute
ATTENTION: metamodel contains several classifiers with same name:
EAnnotation
ATTENTION: metamodel contains several classifiers with same name:
ecore::EAnnotation
ATTENTION: metamodel contains several classifiers with same name: EClass
ATTENTION: metamodel contains several classifiers with same name:
ecore::EClass


and errors like that :

GRAVE: message: ERROR: could not find operation
getAppliedStereotypes on UML2!Class having supertypes:
[UML2!BehavioredClassifier, UML2!EncapsulatedClassifier, OclType,
OclAny] (including Java operations)
and

GRAVE: message: ERROR: could not find operation not on
Sequence(OclAny) having supertypes: [Collection(OclAny)]

Normally the UML2 file and the NsURI option have to do the same
tranformation.

Some one can help me ??
Thank you much.

Jihed
Previous Topic:UUID generation
Next Topic:Missing serialized package: uml.ecore
Goto Forum:
  


Current Time: Tue Aug 16 04:48:02 GMT 2022

Powered by FUDForum. Page generated in 0.01560 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top