Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [Teneo] Association table not created for one-to-many EMF reference
[Teneo] Association table not created for one-to-many EMF reference [message #615940] Thu, 20 March 2008 22:35
Daniel Tuohy is currently offline Daniel TuohyFriend
Messages: 41
Registered: July 2009
Member
Hi Guys,

I noticed that some references in my data (persisted with Teneo) were null
when I reloaded them from the DB. I looked at the DB and found that I was
inexplicably missing one of the association tables. The offending
association is for the EMF-modeled type and reference
"WarfareSystem.dependencies". The corresponding entry in the auto-genned
hbm file is:

<list name="dependencies" lazy="true">
<key update="true" foreign-key="warfaresystem_dependencies">
<column name="`warfaresystem_dependencies_e_id`"
not-null="false" unique="false"/>
</key>
<list-index column="`warfaresystem_dependencies_idx`"/>
<one-to-many entity-name="WarfareSystem"/>
</list>

The relevant mapping info message that is printed to console during the
mapping is:

1969 [main] INFO org.hibernate.cfg.HbmBinder - Mapping collection:
WarfareSystem.dependencies -> warfaresystem

Note that I have an analagous reference for another type that is being
persisted correctly with it's own association table. The entry in the hbm
file is identical (modulo the name/type of the reference), and the info
message is:

1938 [main] INFO org.hibernate.cfg.HbmBinder - Mapping collection:
Step.outputsTo -> step_outputsto

Which I believe is correct. Any idea why this might happen to the
"dependencies" reference? Are there any other diagnostics I can perform to
get you more info?

Daniel
Previous Topic:RE: Merge EMF Models
Next Topic:Teneo API specification online?
Goto Forum:
  


Current Time: Mon Jun 14 05:02:20 GMT 2021

Powered by FUDForum. Page generated in 0.01776 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top